summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Haas <git@haasn.xyz>2020-01-03 11:01:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-01-03 11:14:28 +0200
commit39a3d64de8ce6628faca53874be2d729b6577424 (patch)
treec8a74fbd260a0296daeb3cc6d8dee4e633605f2e /media-libs/libplacebo/libplacebo-1.29.1.ebuild
parentwww-apps/hugo: sort IUSE in 0.62.0 (diff)
downloadgentoo-39a3d64de8ce6628faca53874be2d729b6577424.tar.gz
gentoo-39a3d64de8ce6628faca53874be2d729b6577424.tar.bz2
gentoo-39a3d64de8ce6628faca53874be2d729b6577424.zip
media-libs/libplacebo: update to 1.29.1
This is a minor bug fix release upstream, which also fixes some gentoo-related issues. I also made a minor change to the ebuild, to avoid having to hard-code the subslot version. (Upstream guarantees that the .so version always matches the minor version) Closes: https://bugs.gentoo.org/703570 Closes: https://bugs.gentoo.org/700766 Signed-off-by: Niklas Haas <git@haasn.xyz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/libplacebo/libplacebo-1.29.1.ebuild')
-rw-r--r--media-libs/libplacebo/libplacebo-1.29.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/libplacebo/libplacebo-1.29.1.ebuild b/media-libs/libplacebo/libplacebo-1.29.1.ebuild
new file mode 100644
index 000000000000..ee1709c707f2
--- /dev/null
+++ b/media-libs/libplacebo/libplacebo-1.29.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libplacebo.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://code.videolan.org/videolan/libplacebo/-/archive/v${PV}/libplacebo-v${PV}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+inherit meson multilib-minimal
+
+DESCRIPTION="Reusable library for GPU-accelerated image processing primitives"
+HOMEPAGE="https://github.com/haasn/libplacebo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/$(ver_cut 2)" # libplacebo.so version
+IUSE="glslang lcms +shaderc test +vulkan"
+REQUIRED_USE="vulkan? ( || ( glslang shaderc ) )"
+
+RDEPEND="glslang? ( dev-util/glslang[${MULTILIB_USEDEP}] )
+ lcms? ( media-libs/lcms:2[${MULTILIB_USEDEP}] )
+ shaderc? ( >=media-libs/shaderc-2017.2[${MULTILIB_USEDEP}] )
+ vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature glslang)
+ $(meson_feature lcms)
+ $(meson_feature shaderc)
+ $(meson_feature vulkan)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}