summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-07 15:45:10 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-07 15:56:24 +0100
commit0cd6bebf22f8252ce0b99a8d875e3284b0da0822 (patch)
tree7be4a62e0e752218a655a9d5025923b972900d32 /media-libs/libquvi-scripts
parentmedia-tv/kodi: 19.0_beta2 version bump (diff)
downloadgentoo-0cd6bebf22f8252ce0b99a8d875e3284b0da0822.tar.gz
gentoo-0cd6bebf22f8252ce0b99a8d875e3284b0da0822.tar.bz2
gentoo-0cd6bebf22f8252ce0b99a8d875e3284b0da0822.zip
media-libs/libquvi-scripts: migrate to lua-single.eclass
Does not actually look for Lua, it merely installs scripts to be run by media-libs/libquvi - but since the latter is locked to lua5.1, there is no point in making this one multi-impl at this point. Closes: https://bugs.gentoo.org/752960 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-libs/libquvi-scripts')
-rw-r--r--media-libs/libquvi-scripts/libquvi-scripts-0.9.20131130-r100.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libquvi-scripts/libquvi-scripts-0.9.20131130-r100.ebuild b/media-libs/libquvi-scripts/libquvi-scripts-0.9.20131130-r100.ebuild
new file mode 100644
index 000000000000..7c2917320828
--- /dev/null
+++ b/media-libs/libquvi-scripts/libquvi-scripts-0.9.20131130-r100.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+
+inherit lua-single
+
+DESCRIPTION="Embedded lua scripts for libquvi"
+HOMEPAGE="http://quvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/quvi/${P}.tar.xz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="offensive"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# tests fetch data from live websites
+RESTRICT="test"
+
+RDEPEND="$(lua_gen_cond_dep '
+ >=dev-lua/LuaBitOp-1.0.1-r1[${LUA_USEDEP}]
+ >=dev-lua/luaexpat-1.3.0-r1[${LUA_USEDEP}]
+ >=dev-lua/luajson-1.1.1[${LUA_USEDEP}]
+ >=dev-lua/luasocket-3.0_rc1-r2[${LUA_USEDEP}]
+')"
+
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf $(use_with offensive nsfw) --with-manual
+}