summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-05-16 20:00:14 +0300
committerMart Raudsepp <leio@gentoo.org>2017-05-16 20:03:18 +0300
commit562e8b65c3e8572c4c287ebffc1f7810f83fd9da (patch)
treee118610068d1acb51579a5073421cea3fe916d34 /media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild
parentdev-util/android-ndk: bump to 14b (diff)
downloadgentoo-562e8b65c3e8572c4c287ebffc1f7810f83fd9da.tar.gz
gentoo-562e8b65c3e8572c4c287ebffc1f7810f83fd9da.tar.bz2
gentoo-562e8b65c3e8572c4c287ebffc1f7810f83fd9da.zip
Revert "media-libs/libsamplerate: Cleaning up vulnerable versions for CVE-2017-7697 as per Agostino Sarubbo."
This reverts commit 044005533e2560932dddb0b83c761350867edac3. This was the only ia64 stable ebuild, breaking deptree by the removal.
Diffstat (limited to 'media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild')
-rw-r--r--media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild b/media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..7fb32b200502
--- /dev/null
+++ b/media-libs/libsamplerate/libsamplerate-0.1.8-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio"
+HOMEPAGE="http://www.mega-nerd.com/SRC/"
+SRC_URI="http://www.mega-nerd.com/SRC/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="sndfile static-libs"
+
+RDEPEND="sndfile? ( >=media-libs/libsndfile-1.0.2 )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r6
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-0.1.3-dontbuild-tests-examples.patch"
+ "${FILESDIR}/${P}-lm.patch"
+ )
+
+ AT_M4DIR="M4" \
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ my_configure() {
+ local myeconfargs=(
+ --disable-fftw
+ )
+
+ if [ "${ABI}" = "${DEFAULT_ABI}" ] ; then
+ myeconfargs+=( $(use_enable sndfile) )
+ else
+ myeconfargs+=( --disable-sndfile )
+ fi
+
+ autotools-utils_src_configure
+
+ if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
+ sed -i -e "s/ doc examples//" "${BUILD_DIR}/Makefile" || die
+ fi
+ }
+ multilib_parallel_foreach_abi my_configure
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ htmldocdir="${EPREFIX}/usr/share/doc/${PF}/html"
+}