summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 21:40:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 21:57:46 +0100
commit98871a6eb946031d358895f30ef4d84519f9160c (patch)
tree4a8d489f541489831824d8f57ebc741b232eb7e2 /media-libs/libsidplayfp
parentmedia-sound/sidplay: EAPI-7 bump (diff)
downloadgentoo-98871a6eb946031d358895f30ef4d84519f9160c.tar.gz
gentoo-98871a6eb946031d358895f30ef4d84519f9160c.tar.bz2
gentoo-98871a6eb946031d358895f30ef4d84519f9160c.zip
media-libs/libsidplayfp: 1.8.8 version bump
Closes: https://bugs.gentoo.org/656298 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/libsidplayfp')
-rw-r--r--media-libs/libsidplayfp/Manifest1
-rw-r--r--media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libsidplayfp/Manifest b/media-libs/libsidplayfp/Manifest
index f462c0473b1b..2140d12bde84 100644
--- a/media-libs/libsidplayfp/Manifest
+++ b/media-libs/libsidplayfp/Manifest
@@ -2,3 +2,4 @@ DIST libsidplayfp-0.3.8.tar.gz 682303 BLAKE2B 28bc2f611979f9b9dbbab1764fda99e9f1
DIST libsidplayfp-1.1.0.tar.gz 620228 BLAKE2B 4e51092d84817c6c90ebb0327ba1816c6dae42868f6296f269cdeee1cdf8c226e71e799ab5d7a8609546cb07669dd80f5bd1fb70e14ef594ac128c43a5c7bf51 SHA512 fb0ce00d220772aaf97fc88b7ba3e764f1c94439c9d35713743726872cf6bc6524893489c5909be538f0630896bd328560c6b189d6d2d09932457671080ed76f
DIST libsidplayfp-1.8.0.tar.gz 669469 BLAKE2B 9a5b2da9a696d7b18aacf7dcf9693290d73f22582a5ed3db728f326d1e1ef1b6d0c4258253db51aa6739c471ccbe33b8abeec5c327c131d48453d0fd5ba84b44 SHA512 37af2e0f2a4b635797ce289cba33e0bbe9dea0ec2378da8b4e886f94a34fe09d2941c9deda9568e5325f7da6423f4a9820c814ec8d2970987f3cd03965147c52
DIST libsidplayfp-1.8.1.tar.gz 669478 BLAKE2B af6657ba2eceb40585f9900a72605455b50dc3afb36f091e05b8d9b557ae7dca13c2feb36ecf4a9dbab63e82d3d986a21008034b30189b5e9618518b68385284 SHA512 54731b33071a6bb7300b50c4d899706b71779977d8999302f7aae17d6a9406c9ec407baf87788cae073b04ce6b3f516d90af365b5d95d9dc5525c00cacf79ffd
+DIST libsidplayfp-1.8.8.tar.gz 673522 BLAKE2B 2d31955e08b0b2b9558e033eff5d959acda08cdc5a3c2bb8c0aacb07c4b8c105812b4faa0af07dbc51255c72cfdf4893ce0da4d642dfc0f89ebc6ec96c51db51 SHA512 84fb24dcf6680dd0e2ec9cc39ddaf30707e4beb5136b7b496b1b85bf11580b1080fbb59b6ec3c1dc7b829fa0cd933db89ee3968518f23ef1a35d9253707d6392
diff --git a/media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild b/media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild
new file mode 100644
index 000000000000..bf0faa527c68
--- /dev/null
+++ b/media-libs/libsidplayfp/libsidplayfp-1.8.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Library for the sidplay2 fork with resid-fp"
+HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
+SRC_URI="mirror://sourceforge/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+src_prepare() {
+ default
+ # fix automagic. warning: modifying .ac triggers maintainer mode.
+ sed -i -e 's:doxygen:dIsAbLe&:' configure || die
+}
+
+src_configure() {
+ # relies on undocumented "uint" type in libstdc++
+ # bug 649832
+ append-cxxflags -std=c++14
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx mmx)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}