summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-01 02:55:11 +0100
committerSam James <sam@gentoo.org>2023-10-01 02:55:11 +0100
commit2b21c8fb2d6e89435ebd84e9835c34257b7588b2 (patch)
treee8277d9b5f43fadf7bd033d8bd8e10d255e26322 /media-libs/libvpx
parentdev-python/denonavr: add 0.11.4 (diff)
downloadgentoo-2b21c8fb2d6e89435ebd84e9835c34257b7588b2.tar.gz
gentoo-2b21c8fb2d6e89435ebd84e9835c34257b7588b2.tar.bz2
gentoo-2b21c8fb2d6e89435ebd84e9835c34257b7588b2.zip
media-libs/libvpx: add 1.13.1
Bug: https://bugs.gentoo.org/914987 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libvpx')
-rw-r--r--media-libs/libvpx/Manifest2
-rw-r--r--media-libs/libvpx/libvpx-1.13.1.ebuild141
2 files changed, 143 insertions, 0 deletions
diff --git a/media-libs/libvpx/Manifest b/media-libs/libvpx/Manifest
index a9de9f0b36d7..dd33366cbaf0 100644
--- a/media-libs/libvpx/Manifest
+++ b/media-libs/libvpx/Manifest
@@ -1,4 +1,6 @@
DIST libvpx-1.12.0.tar.gz 5465627 BLAKE2B 92e61ef91ef3bb7e09f359acdef6469843921345b1008a7a24042587fbcfc72c4671fc9eb4e1bf8c1e9de0fa5506ed751dcd6934a9164a6e0fe528cfe8c23154 SHA512 dc059bc3102b75524ae29989372334b3e0f2acf1520e5a4daa4073831bb55949d82897c498fb9d2d38b59f1a66bb0ad24407d0d086b1e3a8394a4933f04f2ed0
DIST libvpx-1.13.0.tar.gz 5515327 BLAKE2B 410be36bf10011171bf15f1219066cf559c8b11e66493f9f722af7217896a467b63934a7e6819144ff697ae90e3ebbac3e5fe93e961d6a68310881c646582f11 SHA512 686cb526b46d5a054d35263b24f54e977149a244e97c95bcdd9aba2d75e045b2d51be2b7f9754302826b4c5450ee2f177f440b41c04c83b8b1661f1c14301c60
+DIST libvpx-1.13.1.tar.gz 5515662 BLAKE2B f7e2fa2880a11c7e40fed8ab5efe843346c351b8de8725aa6803cdebdf9c1253e26992fe3ffed3a68710674765b4d2aec2cce06d22885b722e728d03eaf916f7 SHA512 49706838563c92fab7334376848d0f374efcbc1729ef511e967c908fd2ecd40e8d197f1d85da6553b3a7026bdbc17e5a76595319858af26ce58cb9a4c3854897
DIST libvpx-testdata-1.12.0.tar.xz 499226656 BLAKE2B 8172ecbed4c678593882702c0d24e30d3e5d20a19c55ae73d4470ecd07b03905f25c62e1c32756e27fca2d02c841c11b11f1768dee60fa3419b8b983f6e66bf9 SHA512 28034e5940cd6a433eb6f8924ba5f0f555cb7526ff3356fa66282830a11818c32d2d70f6f9e959b278499397512663bca7f9de17e04b8b209efdf89e9d68ab57
DIST libvpx-testdata-1.13.0.tar.xz 517339584 BLAKE2B 28d61817f7c391001bfe74a0e6270c77516d320dff7d1c95d107fa65e43cd4584a23b187fd65ee07758602781689d7251022898785bb94bfee9e609f606f1283 SHA512 1a0f4e23d1d3c417d3f628a7a5128236fc3ea21b13b1944bb2905ee197c82589d7168f668aaa5d90cec1fbc7983845e14fa047ec9f26ea29d5a2582d9983a24c
+DIST libvpx-testdata-1.13.1.tar.xz 495765552 BLAKE2B 4aba008653b645c1adbfc0f4e20f675712dbe2ee7cf89a240203b8254a463e0ed83f1e90ab49459ed5bf0489c94feeb12a307b6f05c876404393bb2ed2fe5e0f SHA512 16bfb947c83cb1a8bccbe5c0a533ed2f946c2b207640e0813dd28c1109177157f045ad5679e8a6146482fab48586e9dffccbfeff1cb05ab3dba02e48e9c31bd8
diff --git a/media-libs/libvpx/libvpx-1.13.1.ebuild b/media-libs/libvpx/libvpx-1.13.1.ebuild
new file mode 100644
index 000000000000..f383dae1d20f
--- /dev/null
+++ b/media-libs/libvpx/libvpx-1.13.1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs multilib-minimal
+
+# To create a new testdata tarball:
+# 1. Unpack source tarball or checkout git tag
+# 2. mkdir libvpx-testdata
+# 3. export LIBVPX_TEST_DATA_PATH=libvpx-testdata
+# 4. ./configure --enable-unit-tests --enable-vp9-highbitdepth
+# 5. make testdata
+# 6. tar -caf libvpx-testdata-${MY_PV}.tar.xz libvpx-testdata
+
+LIBVPX_TESTDATA_VER=1.13.1
+
+DESCRIPTION="WebM VP8 and VP9 Codec SDK"
+HOMEPAGE="https://www.webmproject.org"
+SRC_URI="
+ https://github.com/webmproject/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-testdata-${LIBVPX_TESTDATA_VER}.tar.xz )
+"
+
+LICENSE="BSD"
+SLOT="0/8"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_ppc_vsx3 doc +highbitdepth postproc static-libs test +threads"
+REQUIRED_USE="test? ( threads )"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-lang/perl
+ abi_x86_32? ( dev-lang/yasm )
+ abi_x86_64? ( dev-lang/yasm )
+ abi_x86_x32? ( dev-lang/yasm )
+ doc? (
+ app-doc/doxygen
+ dev-lang/php
+ )
+"
+
+PATCHES=(
+ # bug #501010
+ "${FILESDIR}/${PN}-1.3.0-sparc-configure.patch"
+)
+
+src_configure() {
+ # bug #384585, bug #465988
+ # copied from php-pear-r1.eclass
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+ addpredict /var/lib/net-snmp/mib_indexes
+ addpredict /session_mm_cli0.sem
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # bug #357487
+ unset CODECS
+ # bug #905986
+ unset DIST_DIR
+
+ # bug #498364: sse doesn't work without sse2 enabled,
+ local myconfargs=(
+ --prefix="${EPREFIX}"/usr
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --enable-pic
+ --enable-vp8
+ --enable-vp9
+ --enable-shared
+ --disable-optimizations
+ $(use_enable postproc)
+ $(use_enable static-libs static)
+ $(use_enable test unit-tests)
+ $(use_enable threads multithread)
+ $(use_enable highbitdepth vp9-highbitdepth)
+ )
+
+ # let the build system decide which AS to use (it honours $AS but
+ # then feeds it with yasm flags without checking...), bug #345161
+ tc-export AS
+ case "${CHOST}" in
+ i?86*) export AS=yasm;;
+ x86_64*) export AS=yasm;;
+ esac
+
+ # libvpx is fragile: both for tests at runtime.
+ # We force using the generic target unless we know things work to
+ # avoid runtime breakage on exotic arches.
+ if [[ ${ABI} == amd64 ]] ; then
+ myconfargs+=( --force-target=x86_64-linux-gcc )
+ elif [[ ${ABI} == x86 ]] ; then
+ myconfargs+=( --force-target=x86-linux-gcc )
+ elif [[ ${ABI} == arm64 ]] ; then
+ myconfargs+=( --force-target=arm64-linux-gcc )
+ elif [[ ${ABI} == arm ]] && [[ ${CHOST} == *armv7* ]] ; then
+ myconfargs+=( --force-target=armv7-linux-gcc )
+ elif [[ ${ABI} == ppc64 ]] && [[ $(tc-endian) != big ]] && use cpu_flags_ppc_vsx3; then
+ # only enable this target for at least power9 CPU running little-endian
+ myconfargs+=( --force-target=ppc64le-linux-gcc )
+ else
+ myconfargs+=( --force-target=generic-gnu )
+ fi
+
+ # powerpc toolchain is not recognized anymore, bug #694368
+ #[[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
+ # Build with correct toolchain.
+ tc-export CC CXX AR NM
+ # Link with gcc by default, the build system should override this if needed.
+ export LD="${CC}"
+
+ if multilib_is_native_abi; then
+ myconfargs+=( $(use_enable doc install-docs) $(use_enable doc docs) )
+ else
+ # Not needed for multilib and will be overwritten anyway.
+ myconfargs+=( --disable-examples --disable-install-docs --disable-docs )
+ fi
+
+ edo "${S}"/configure "${myconfargs[@]}"
+}
+
+multilib_src_compile() {
+ # Build verbose by default and do not build examples that will not be installed
+ # Disable stripping of debug info, bug #752057
+ # (only works as long as upstream does not use non-gnu strip)
+ emake verbose=yes GEN_EXAMPLES= HAVE_GNU_STRIP=no
+}
+
+multilib_src_test() {
+ local -x LD_LIBRARY_PATH="${BUILD_DIR}"
+ local -x LIBVPX_TEST_DATA_PATH="${WORKDIR}/${PN}-testdata"
+ emake verbose=yes GEN_EXAMPLES= test
+}
+
+multilib_src_install() {
+ emake verbose=yes GEN_EXAMPLES= DESTDIR="${D}" install
+
+ multilib_is_native_abi && use doc && dodoc -r docs/html
+}