summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-06 10:33:43 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-06 10:33:43 +0100
commit54d96a586b918e8549aed6353b7f29624e7cb484 (patch)
treee5b7795b5d728984494d43aef75972839a686eaa /media-libs/lilv
parentmedia-libs/lilv: remove old (diff)
downloadgentoo-54d96a586b918e8549aed6353b7f29624e7cb484.tar.gz
gentoo-54d96a586b918e8549aed6353b7f29624e7cb484.tar.bz2
gentoo-54d96a586b918e8549aed6353b7f29624e7cb484.zip
media-libs/lilv: bump to 0.24.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/lilv')
-rw-r--r--media-libs/lilv/Manifest1
-rw-r--r--media-libs/lilv/lilv-0.24.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/lilv/Manifest b/media-libs/lilv/Manifest
index 37c66e88df04..0648fe209e43 100644
--- a/media-libs/lilv/Manifest
+++ b/media-libs/lilv/Manifest
@@ -1,2 +1,3 @@
DIST lilv-0.20.0.tar.bz2 207948 SHA256 428a39f1265d44c55f2604829a12ade0ea13e1a1022ff937ca2a9ad227bd422a SHA512 bbc8b9154339cd145a61c5e4613fd31a2e457df8242c55371f3245564d3b23d028a0bc0ffafac393119bb47171b7c735f0c3a55cf5bffc6920ae89aa877240e5 WHIRLPOOL 1e71e553f1b969d40042633c9eb63b96ef1f9d72d8087326414f840ffe8ee38094f63cabf0efc57dece04471e7d4897140fbb886bad21f11a6282d420530d51c
DIST lilv-0.24.0.tar.bz2 244079 SHA256 fa60de536d3648aa3b1a445261fd77bd80d0246a071eed2e7ca51ea91a27fb9e SHA512 2a5523385e4cb3876abb49d8cd4eb7b8f95b886d8e9dd3155588a0bef7b5ffd7486501a70cb852d4965592ffe7ef8335d8e46666f519b5214753dd9ae96a1756 WHIRLPOOL a079de92a03d28205b7f7d08e99bee4e84f31469b4e91053bea4348f620ebaf61ef8c6ce94c8a0dd18b7a36b01e7907d077ebd066a86789e7b1d4c31a7a6dc96
+DIST lilv-0.24.2.tar.bz2 244764 SHA256 f7ec65b1c1f1734ded3a6c051bbaf50f996a0b8b77e814a33a34e42bce50a522 SHA512 b5d04b6bb1fb4d3a9a58d93b233db502dc2ded75672766a31d252abca657cbf2d170fa590c0c56159b2bac68c7af95d8787a512e318e3a0f30855504bb034659 WHIRLPOOL 71db87acb85e194cd1fc8fc235c3319164aacb24de11fd21cb1d144a661dc06cde60c5be2fd1fc820bd19c4ec706fd1c5d52cc8c67aefdba874f6dd61333448f
diff --git a/media-libs/lilv/lilv-0.24.2.ebuild b/media-libs/lilv/lilv-0.24.2.ebuild
new file mode 100644
index 000000000000..102b4939756f
--- /dev/null
+++ b/media-libs/lilv/lilv-0.24.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit base python-any-r1 waf-utils bash-completion-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://drobilla.net/software/lilv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc +dyn-manifest static-libs test"
+
+RDEPEND=">=media-libs/lv2-1.14.0
+ >=media-libs/sratom-0.4.0
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.13.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --no-bash-completion \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static") \
+ $(use dyn-manifest && echo "--dyn-manifest")
+}
+
+src_test() {
+ ./waf test || die
+}
+
+src_install() {
+ waf-utils_src_install
+ newbashcomp utils/lilv.bash_completion ${PN}
+}