summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-25 15:07:35 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-25 15:14:17 -0800
commitbc010550b9249b047b349b200c39fe7314b39446 (patch)
tree9160a8f99fe18292f690e5625a98a2553519e946 /media-libs/mesa
parentapp-vim/nerdtree-tabs: clean up old. (diff)
downloadgentoo-bc010550b9249b047b349b200c39fe7314b39446.tar.gz
gentoo-bc010550b9249b047b349b200c39fe7314b39446.tar.bz2
gentoo-bc010550b9249b047b349b200c39fe7314b39446.zip
media-libs/mesa: Drop kernel_FreeBSD exclusion of libelf dependency.
In commit cc7c79df20b, Chí-Thanh removed the libelf dependency on FreeBSD since it is a part of sys-freebsd/freebsd-lib. Since then (see commit 7f40b6c262bfe5) we have switched to virtual/libelf, which is satisfied by sys-freebsd/freebsd-lib.
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-13.0.3.ebuild8
-rw-r--r--media-libs/mesa/mesa-17.0.0_rc2.ebuild8
-rw-r--r--media-libs/mesa/mesa-9999.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/media-libs/mesa/mesa-13.0.3.ebuild b/media-libs/mesa/mesa-13.0.3.ebuild
index 07737860936d..f539cdcf9040 100644
--- a/media-libs/mesa/mesa-13.0.3.ebuild
+++ b/media-libs/mesa/mesa-13.0.3.ebuild
@@ -45,7 +45,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gcrypt gles1 gles2
libressl +llvm +nettle +nptl opencl osmesa pax_kernel openmax openssl pic
- selinux vaapi valgrind vdpau vulkan wayland xvmc xa kernel_FreeBSD"
+ selinux vaapi valgrind vdpau vulkan wayland xvmc xa"
REQUIRED_USE="
|| ( gcrypt libressl nettle openssl )
@@ -95,11 +95,11 @@ RDEPEND="
>=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
>=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
- llvm? ( !kernel_FreeBSD? (
+ llvm? (
video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
!video_cards_r600? (
video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
- ) )
+ )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
nettle? ( dev-libs/nettle:=[${MULTILIB_USEDEP}] )
@@ -113,7 +113,7 @@ RDEPEND="
opencl? (
app-eselect/eselect-opencl
dev-libs/libclc
- !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
)
openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
vaapi? (
diff --git a/media-libs/mesa/mesa-17.0.0_rc2.ebuild b/media-libs/mesa/mesa-17.0.0_rc2.ebuild
index 735dd56f2fe0..1df4dd09aee3 100644
--- a/media-libs/mesa/mesa-17.0.0_rc2.ebuild
+++ b/media-libs/mesa/mesa-17.0.0_rc2.ebuild
@@ -44,7 +44,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
+nptl opencl osmesa pax_kernel openmax pic selinux vaapi valgrind vdpau
- vulkan wayland xvmc xa kernel_FreeBSD"
+ vulkan wayland xvmc xa"
REQUIRED_USE="
d3d9? ( dri3 gallium )
@@ -95,17 +95,17 @@ RDEPEND="
>=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
>=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
- llvm? ( !kernel_FreeBSD? (
+ llvm? (
video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
!video_cards_r600? (
video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
- ) )
+ )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
opencl? (
app-eselect/eselect-opencl
dev-libs/libclc
- !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
)
openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
vaapi? (
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 2268df1cdccb..b8ea0e0c8818 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -44,7 +44,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
+nptl opencl osmesa pax_kernel openmax pic selinux vaapi valgrind vdpau
- vulkan wayland xvmc xa kernel_FreeBSD"
+ vulkan wayland xvmc xa"
REQUIRED_USE="
d3d9? ( dri3 gallium )
@@ -95,17 +95,17 @@ RDEPEND="
>=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
>=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
- llvm? ( !kernel_FreeBSD? (
+ llvm? (
video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
!video_cards_r600? (
video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
- ) )
+ )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
opencl? (
app-eselect/eselect-opencl
dev-libs/libclc
- !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
)
openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
vaapi? (