summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-28 19:56:34 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-28 21:41:15 +0200
commit14de73d6ad30dd69cb1eee16eeedf96792c98a56 (patch)
treea0d739fd0c6de71cddfc5183da9bdab751f54d1e /media-libs/mlt
parentnet-analyzer/ntopng: Fix fowners call not to use EPREFIX (diff)
downloadgentoo-14de73d6ad30dd69cb1eee16eeedf96792c98a56.tar.gz
gentoo-14de73d6ad30dd69cb1eee16eeedf96792c98a56.tar.bz2
gentoo-14de73d6ad30dd69cb1eee16eeedf96792c98a56.zip
media-libs/mlt: Fix installing Python & Ruby files
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/mlt')
-rw-r--r--media-libs/mlt/mlt-6.16.0-r1.ebuild9
-rw-r--r--media-libs/mlt/mlt-6.16.0-r2.ebuild9
2 files changed, 8 insertions, 10 deletions
diff --git a/media-libs/mlt/mlt-6.16.0-r1.ebuild b/media-libs/mlt/mlt-6.16.0-r1.ebuild
index 76fc970c2228..dc4435ed3601 100644
--- a/media-libs/mlt/mlt-6.16.0-r1.ebuild
+++ b/media-libs/mlt/mlt-6.16.0-r1.ebuild
@@ -209,17 +209,16 @@ src_install() {
if use python; then
cd "${S}"/src/swig/python || die
- insinto $(python_get_sitedir)
- doins mlt.py
- exeinto $(python_get_sitedir)
- doexe _mlt.so
+ python_domodule mlt.py _mlt.so
+ chmod +x "${D}$(python_get_sitedir)/_mlt.so" || die
dodoc play.py
python_optimize
fi
if use ruby; then
cd "${S}"/src/swig/ruby || die
- exeinto $("${EPREFIX}"/usr/bin/${USE_RUBY} -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')
+ local rubydir=$("${EPREFIX}"/usr/bin/${USE_RUBY} -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')
+ exeinto "${rubydir#${EPREFIX}}"
doexe mlt.so
dodoc play.rb thumbs.rb
fi
diff --git a/media-libs/mlt/mlt-6.16.0-r2.ebuild b/media-libs/mlt/mlt-6.16.0-r2.ebuild
index 31ed25573ff9..f509af5ceede 100644
--- a/media-libs/mlt/mlt-6.16.0-r2.ebuild
+++ b/media-libs/mlt/mlt-6.16.0-r2.ebuild
@@ -209,17 +209,16 @@ src_install() {
if use python; then
cd "${S}"/src/swig/python || die
- insinto $(python_get_sitedir)
- doins mlt.py
- exeinto $(python_get_sitedir)
- doexe _mlt.so
+ python_domodule mlt.py _mlt.so
+ chmod +x "${D}$(python_get_sitedir)/_mlt.so" || die
dodoc play.py
python_optimize
fi
if use ruby; then
cd "${S}"/src/swig/ruby || die
- exeinto $("${EPREFIX}"/usr/bin/${USE_RUBY} -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')
+ local rubydir=$("${EPREFIX}"/usr/bin/${USE_RUBY} -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')
+ exeinto "${rubydir#${EPREFIX}}"
doexe mlt.so
dodoc play.rb thumbs.rb
fi