summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-01-01 21:13:41 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-01-03 01:10:28 +1100
commite97148380ac11516c3f8b406952c5259fdaba333 (patch)
tree6d1ccb6f3a2f91aa335aa88bcea00a304a40282c /media-libs/mlt
parentMerge remote-tracking branch 'github/pr/591'. (diff)
downloadgentoo-e97148380ac11516c3f8b406952c5259fdaba333.tar.gz
gentoo-e97148380ac11516c3f8b406952c5259fdaba333.tar.bz2
gentoo-e97148380ac11516c3f8b406952c5259fdaba333.zip
media-libs/mlt: Fix build with USE=gtk caused by wrong arch, bug 570508
Use tc-arch instead of tc-arch-kernel Package-Manager: portage-2.2.24
Diffstat (limited to 'media-libs/mlt')
-rw-r--r--media-libs/mlt/mlt-0.9.8-r1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/media-libs/mlt/mlt-0.9.8-r1.ebuild b/media-libs/mlt/mlt-0.9.8-r1.ebuild
index 97a6e4483315..71759e9cf006 100644
--- a/media-libs/mlt/mlt-0.9.8-r1.ebuild
+++ b/media-libs/mlt/mlt-0.9.8-r1.ebuild
@@ -5,7 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python2_7 )
USE_RUBY="ruby19"
-inherit eutils toolchain-funcs linux-info multilib python-single-r1 ruby-single
+inherit eutils toolchain-funcs multilib python-single-r1 ruby-single
DESCRIPTION="Open source multimedia framework for television broadcasting"
HOMEPAGE="http://www.mltframework.org/"
@@ -88,7 +88,6 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
"
pkg_setup() {
- linux-info_pkg_setup
use python && python-single-r1_pkg_setup
}
@@ -110,7 +109,7 @@ src_configure() {
local myconf="--enable-gpl
--enable-gpl3
--enable-motion-est
- --target-arch=$(tc-arch-kernel)
+ --target-arch=$(tc-arch)
--disable-swfdec
$(use_enable debug)
$(use compressed-lumas && echo ' --luma-compress')