summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/opencollada/opencollada-1.2.2_p20150207.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/opencollada/opencollada-1.2.2_p20150207.ebuild')
-rw-r--r--media-libs/opencollada/opencollada-1.2.2_p20150207.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/opencollada/opencollada-1.2.2_p20150207.ebuild b/media-libs/opencollada/opencollada-1.2.2_p20150207.ebuild
new file mode 100644
index 000000000000..2ed6d67a53e4
--- /dev/null
+++ b/media-libs/opencollada/opencollada-1.2.2_p20150207.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == *9999* ]] ; then
+ SCM_ECLASS="git-r3"
+else
+ SCM_ECLASS="vcs-snapshot"
+fi
+
+inherit versionator eutils multilib cmake-utils ${SCM_ECLASS}
+
+DESCRIPTION="Stream based read/write library for COLLADA files"
+HOMEPAGE="http://www.opencollada.org/"
+LICENSE="MIT"
+IUSE="expat"
+
+# seems like the Khronos Group hasnt invented the SOVERSION yet
+MY_SOVERSION="1.2"
+
+SLOT="0"
+
+if [[ ${PV} != *9999* ]]; then
+ #
+ # UPDATE THE COMMIT WHEN BUMPING!
+ COMMIT="ceb409cabdccda3000aa2e5c065850b8fde60b0f"
+ #
+ SRC_URI="https://github.com/KhronosGroup/OpenCOLLADA/tarball/${COMMIT} -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~ppc64 x86"
+else
+ EGIT_REPO_URI="http://github.com/KhronosGroup/OpenCOLLADA.git"
+fi
+
+RDEPEND="dev-libs/libpcre
+ dev-libs/zziplib
+ media-libs/lib3ds
+ sys-libs/zlib
+ >=sys-devel/gcc-4.7
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ sys-apps/findutils
+ sys-apps/sed"
+
+BUILD_DIR="${S}"/build
+
+src_prepare() {
+
+ # Remove some bundled dependencies
+ edos2unix CMakeLists.txt || die
+
+ epatch "${FILESDIR}"/${PN}-0_p864-expat.patch
+
+ epatch "${FILESDIR}"/${PN}-1.2.2-soversion.patch
+ epatch "${FILESDIR}"/${PN}-1.2.2-no-undefined.patch
+ epatch "${FILESDIR}"/${PN}-1.2.2-libdir.patch
+
+ rm -R Externals/{expat,lib3ds,LibXML,pcre,zlib,zziplib} || die
+ ewarn "$(echo "Remaining bundled dependencies:";
+ find Externals -mindepth 1 -maxdepth 1 -type d | sed 's|^|- |')"
+
+ # Remove unused build systems
+ rm Makefile scripts/{unixbuild.sh,vcproj2cmake.rb} || die
+ find "${S}" -name SConscript -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=" -DUSE_SHARED=ON -DUSE_STATIC=OFF"
+
+ # Master CMakeLists.txt says "EXPAT support not implemented"
+ # Something like "set(LIBEXPAT_LIBRARIES expat)" is missing to make it build
+ use expat \
+ && mycmakeargs+=' -DUSE_EXPAT=ON -DUSE_LIBXML=OFF' \
+ || mycmakeargs+=' -DUSE_EXPAT=OFF -DUSE_LIBXML=ON'
+
+ # Seems like the Khronos Group hasnt invented the SOVERSION yet.
+ mycmakeargs+=" -Dsoversion=${MY_SOVERSION}"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodir /etc/env.d || die
+ echo "LDPATH=/usr/$(get_libdir)/opencollada" \
+ > "${D}"/etc/env.d/99opencollada || die
+
+ dobin build/bin/OpenCOLLADAValidator || die
+}