summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-26 11:49:25 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-26 13:46:53 -0700
commita232a9da5922f62dfb73eba78b360bc5eb2e8a19 (patch)
treea75f7b0ebbb06fcce3ce61e67e82832608db67d9 /media-libs/opencv
parentmedia-libs/tiff: drop vulnerable wrt bug #667638 (diff)
downloadgentoo-a232a9da5922f62dfb73eba78b360bc5eb2e8a19.tar.gz
gentoo-a232a9da5922f62dfb73eba78b360bc5eb2e8a19.tar.bz2
gentoo-a232a9da5922f62dfb73eba78b360bc5eb2e8a19.zip
media-libs/opencv: fix python build with cmake 3.14
Closes: https://bugs.gentoo.org/680824 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Acked-by: Amy Liffey <amynka@gentoo.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/opencv-3.4.1-r5.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/media-libs/opencv/opencv-3.4.1-r5.ebuild b/media-libs/opencv/opencv-3.4.1-r5.ebuild
index c8bf140695b9..092e2a0d7ebc 100644
--- a/media-libs/opencv/opencv-3.4.1-r5.ebuild
+++ b/media-libs/opencv/opencv-3.4.1-r5.ebuild
@@ -472,10 +472,9 @@ python_module_compile() {
# Set all python variables to load the correct Gentoo paths
mycmakeargs+=(
- # cheap trick: python_setup sets one of them as a symlink
- # to the correct interpreter, and the other to fail-wrapper
- -DPYTHON2_EXECUTABLE=$(type -P python2)
- -DPYTHON3_EXECUTABLE=$(type -P python3)
+ # python_setup alters PATH and sets this as wrapper
+ # to the correct interpreter we are building for
+ -DPYTHON_DEFAULT_EXECUTABLE=python
-DINSTALL_PYTHON_EXAMPLES=$(usex examples)
-DLIBPY_SUFFIX=64
)