summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2018-09-30 21:45:39 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-11 20:42:49 +0200
commit086e36c12dff193371ce5fe3e54fb9058f1e9d52 (patch)
tree1bf8b7286ac43e0be217b53aa6fdc5b8b38c1a10 /media-libs/openexr/openexr-2.3.0.ebuild
parentmedia-libs/ilmbase: bump to version 2.3.0 (diff)
downloadgentoo-086e36c12dff193371ce5fe3e54fb9058f1e9d52.tar.gz
gentoo-086e36c12dff193371ce5fe3e54fb9058f1e9d52.tar.bz2
gentoo-086e36c12dff193371ce5fe3e54fb9058f1e9d52.zip
media-libs/openexr: bump to version 2.3.0
Closes: https://bugs.gentoo.org/639998 Suggested-by: Jonathan Scruggs <dracwyrm@gentoo.org> Signed-off-by: Bernd Waibel <waebbl@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/openexr/openexr-2.3.0.ebuild')
-rw-r--r--media-libs/openexr/openexr-2.3.0.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/openexr/openexr-2.3.0.ebuild b/media-libs/openexr/openexr-2.3.0.ebuild
new file mode 100644
index 000000000000..99f63d05e1f9
--- /dev/null
+++ b/media-libs/openexr/openexr-2.3.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="https://github.com/openexr/openexr/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/24" # based on SONAME
+KEYWORDS="~amd64 -arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="cpu_flags_x86_avx examples static-libs"
+
+RDEPEND="
+ >=media-libs/ilmbase-${PV}:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-archive-2016.09.16
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/OpenEXRConfig.h )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-fix-cpuid-on-abi_x86_32.patch"
+ "${FILESDIR}/${PN}-2.2.0-fix-config.h-collision.patch"
+ "${FILESDIR}/${PN}-2.2.0-Install-missing-header-files.patch"
+ "${FILESDIR}/${P}-fix-build-system.patch"
+)
+
+src_prepare() {
+ default
+ # Fix path for testsuite
+ sed -i -e "s:/var/tmp/:${T}:" IlmImfTest/tmpDir.h || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-imffuzztest
+ --disable-imfhugetest
+ --enable-threading
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable examples imfexamples)
+ $(use_enable static-libs static)
+ )
+
+ # TODO: check if this still applies on updates!
+ # internal tool dwaLookup fails to run when linked with gold linker
+ tc-ld-disable-gold
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -rf "${ED%/}"/usr/share/doc/${PF}/examples || die
+ fi
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}