summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-09-13 21:33:35 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-09-13 21:33:35 +0100
commit48477c5f5e055718357ef4e18516ba9239b35532 (patch)
tree729e55a41cb21b7c24e04006a300c45ec7bfe1f1 /media-libs/openglide
parentlxde-base/lxde-meta: New lxde meta ebuild (diff)
downloadgentoo-48477c5f5e055718357ef4e18516ba9239b35532.tar.gz
gentoo-48477c5f5e055718357ef4e18516ba9239b35532.tar.bz2
gentoo-48477c5f5e055718357ef4e18516ba9239b35532.zip
media-libs/openglide: New package for emulating Glide
The original upstream is dead but I have been contributing to a fork on GitHub that's being maintained by another Gentoo user. Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs/openglide')
-rw-r--r--media-libs/openglide/Manifest1
-rw-r--r--media-libs/openglide/files/OpenGLid.ini26
-rw-r--r--media-libs/openglide/metadata.xml21
-rw-r--r--media-libs/openglide/openglide-0.09_rc9_p20160913.ebuild62
4 files changed, 110 insertions, 0 deletions
diff --git a/media-libs/openglide/Manifest b/media-libs/openglide/Manifest
new file mode 100644
index 000000000000..7c96b2175596
--- /dev/null
+++ b/media-libs/openglide/Manifest
@@ -0,0 +1 @@
+DIST openglide-0.09_rc9_p20160913.tar.gz 450667 SHA256 136528469596e43595fd3e9a44e9b25b97e12617a3cee8469c8020b470a66cbd SHA512 4a64b74c2a96639d9fac732f72419ced652989b347b484f4abf7ac6a33d7b8d89ee56e6c04aaaf7475cae332b69a98ec0b7c58a9aac25a24d8acaad92392cb38 WHIRLPOOL 76e816031a01c700704bda1b7c6413ed8481412ca78f4b25852ca8a2bea3fb494ae14468b52de4ab499d8b2bf2e5c5ba85bdd3c30bdb956b22d95e5b2066e28e
diff --git a/media-libs/openglide/files/OpenGLid.ini b/media-libs/openglide/files/OpenGLid.ini
new file mode 100644
index 000000000000..d4ae7490a4bd
--- /dev/null
+++ b/media-libs/openglide/files/OpenGLid.ini
@@ -0,0 +1,26 @@
+Configuration File for OpenGLide
+
+Info:
+Priority goes from 0(HIGH) to 5(IDLE)
+Output resolution: 0 = original, 1.0-16.0 = scale factor, >16 = fixed width (height calculated automatically)
+Texture Memory goes from 2 to 32
+Frame Buffer Memory goes from 2 to 16
+All other fields are boolean with 1(TRUE) and 0(FALSE)
+
+Version=0.09rc9
+
+[Options]
+WrapperPriority=2
+CreateWindow=0
+InitFullScreen=1
+Resolution=0.0
+EnableMipMaps=1
+IgnorePaletteChange=0
+Wrap565to5551=1
+EnablePrecisionFix=1
+EnableMultiTextureEXT=1
+EnablePaletteEXT=1
+EnableVertexArrayEXT=0
+TextureMemorySize=32
+FrameBufferMemorySize=16
+NoSplash=1
diff --git a/media-libs/openglide/metadata.xml b/media-libs/openglide/metadata.xml
new file mode 100644
index 000000000000..b14a9fd7bc1b
--- /dev/null
+++ b/media-libs/openglide/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">voyageur/openglide</remote-id>
+ <remote-id type="sourceforge">openglide</remote-id>
+ </upstream>
+ <longdescription>
+ OpenGLide is a Glide to OpenGL wrapper. It emulates a Voodoo
+ board so you can run old DOS/Windows Glide games by translating
+ Glide calls into OpenGL.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-libs/openglide/openglide-0.09_rc9_p20160913.ebuild b/media-libs/openglide/openglide-0.09_rc9_p20160913.ebuild
new file mode 100644
index 000000000000..15df0a8dfdc9
--- /dev/null
+++ b/media-libs/openglide/openglide-0.09_rc9_p20160913.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+COMMIT="3722fc563b737d2d7933df6a771651c2154e6f7b"
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A Glide to OpenGL wrapper"
+HOMEPAGE="http://openglide.sourceforge.net/"
+SRC_URI="https://github.com/voyageur/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sdl static-libs"
+
+RDEPEND="virtual/glu:=[${MULTILIB_USEDEP}]
+ virtual/opengl:=[${MULTILIB_USEDEP}]
+ sdl? (
+ media-libs/libsdl:=[${MULTILIB_USEDEP}]
+ )
+ !sdl? (
+ x11-libs/libICE:=[${MULTILIB_USEDEP}]
+ x11-libs/libSM:=[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm:=[${MULTILIB_USEDEP}]
+ )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+ECONF_SOURCE="${S}"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/openglide/sdk2_unix.h
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ econf \
+ --enable-shared \
+ --disable-sdltest \
+ $(use_enable sdl) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ insinto /etc
+ doins "${FILESDIR}"/OpenGLid.ini
+
+ exeinto /usr/share/${PN}
+ newexe platform/dosbox/glide2x.ovl glide2x-dosbox.ovl
+ newexe platform/dosemu/glide2x.ovl glide2x-dosemu.ovl
+
+ prune_libtool_files
+ einstalldocs
+}