summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-09-21 10:14:47 +0100
committerDavid Seifert <soap@gentoo.org>2017-09-23 10:36:15 +0200
commit072d9adafab829b7f934637f7ba8a8f29c2ea3db (patch)
treec88542658849c15f2dc1a3f97ab7ef2e564cdad6 /media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
parentmedia-libs/opencolorio: Update to v20170719 (diff)
downloadgentoo-072d9adafab829b7f934637f7ba8a8f29c2ea3db.tar.gz
gentoo-072d9adafab829b7f934637f7ba8a8f29c2ea3db.tar.bz2
gentoo-072d9adafab829b7f934637f7ba8a8f29c2ea3db.zip
media-libs/opensubdiv: Version bump to 3.3 and remove ati-drivers
* Fixed compile error about stray quotes * Changed hardcoded paths to GNUInstallDirs which fixed multilib-strict check fail Closes: https://bugs.gentoo.org/605958 Closes: https://bugs.gentoo.org/611844 Closes: https://github.com/gentoo/gentoo/pull/5751
Diffstat (limited to 'media-libs/opensubdiv/opensubdiv-3.1.1.ebuild')
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
index df840a1c2750..0003926a6d4b 100644
--- a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
@@ -15,10 +15,8 @@ LICENSE="ZLIB"
SLOT="0"
IUSE="cuda doc examples opencl openmp ptex tbb tutorials"
-# OpenCL does not work with Open Source drivers or nVidia binaries.
RDEPEND="media-libs/glew:=
media-libs/glfw:=
- opencl? ( x11-drivers/ati-drivers:* )
cuda? ( dev-util/nvidia-cuda-toolkit:* )
ptex? ( media-libs/ptex )"
@@ -38,6 +36,13 @@ pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e 's|"${OSD_SONAME}"|${OSD_SONAME}|' \
+ -i CMakeLists.txt || die
+}
+
src_configure() {
local mycmakeargs=(
-DNO_MAYA=1