summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-10-11 19:15:27 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-10-15 23:11:06 +0200
commit91bc5e72afb058ff82626e49cacb9515d0e22307 (patch)
treeb4ff1ff56116c7fcb9673cc50f5c43181b94be74 /media-libs/opensubdiv
parentnet-misc/bopm: fix security bug with pid file. (diff)
downloadgentoo-91bc5e72afb058ff82626e49cacb9515d0e22307.tar.gz
gentoo-91bc5e72afb058ff82626e49cacb9515d0e22307.tar.bz2
gentoo-91bc5e72afb058ff82626e49cacb9515d0e22307.zip
media-libs/opensubdiv: ebuild and metadata fixes.
* remove tutorial use flag from metadata.xml. * remove examples and tutorials as they violate installation location rules. Closes: https://bugs.gentoo.org/633756 Closes: https://github.com/gentoo/gentoo/pull/5919
Diffstat (limited to 'media-libs/opensubdiv')
-rw-r--r--media-libs/opensubdiv/metadata.xml2
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.0.ebuild6
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.1.ebuild6
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.0.ebuild8
4 files changed, 10 insertions, 12 deletions
diff --git a/media-libs/opensubdiv/metadata.xml b/media-libs/opensubdiv/metadata.xml
index f4db4009bdda..8a3f73ac7b22 100644
--- a/media-libs/opensubdiv/metadata.xml
+++ b/media-libs/opensubdiv/metadata.xml
@@ -33,8 +33,6 @@
Enable OpenCL support through
<pkg>virtual/opencl</pkg>.
</flag>
- <flag name="tutorials">
- </flag>
</use>
<upstream>
<remote-id type="github">PixarAnimationStudios/OpenSubdiv</remote-id>
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
index d822c40cc99e..aa63d90eeda4 100644
--- a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.t
LICENSE="ZLIB"
SLOT="0"
-IUSE="cuda doc examples opencl openmp ptex tbb test tutorials"
+IUSE="cuda doc opencl openmp ptex tbb test"
RDEPEND="media-libs/glew:=
media-libs/glfw:=
@@ -49,8 +49,8 @@ src_configure() {
-DNO_OPENCL=$(usex !opencl)
-DNO_CUDA=$(usex !cuda)
-DNO_REGRESSION=$(usex !test)
- -DNO_EXAMPLES=$(usex !examples)
- -DNO_TUTORIALS=$(usex !tutorials)
+ -DNO_EXAMPLES=1 # broken
+ -DNO_TUTORIALS=1 # broken
-DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
)
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
index 0003926a6d4b..5c1768b6b37c 100644
--- a/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.1.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.t
LICENSE="ZLIB"
SLOT="0"
-IUSE="cuda doc examples opencl openmp ptex tbb tutorials"
+IUSE="cuda doc opencl openmp ptex tbb"
RDEPEND="media-libs/glew:=
media-libs/glfw:=
@@ -54,8 +54,8 @@ src_configure() {
-DNO_OPENCL=$(usex !opencl)
-DNO_CUDA=$(usex !cuda)
-DNO_REGRESSION=1 # The don't work with certain settings
- -DNO_EXAMPLES=$(usex !examples)
- -DNO_TUTORIALS=$(usex !tutorials)
+ -DNO_EXAMPLES=1 # Broken
+ -DNO_TUTORIALS=1 # Broken
-DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
)
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
index b73f2a25deb5..28ba08cb7a52 100644
--- a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.t
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cuda doc examples opencl openmp ptex tbb tutorials"
+IUSE="cuda doc opencl openmp ptex tbb"
RDEPEND="media-libs/glew:=
media-libs/glfw:=
@@ -21,7 +21,7 @@ RDEPEND="media-libs/glew:=
DEPEND="${RDEPEND}
tbb? ( dev-cpp/tbb )
- doc? (
+ doc? (
dev-python/docutils
app-doc/doxygen
)"
@@ -52,8 +52,8 @@ src_configure() {
-DNO_OPENCL=$(usex !opencl)
-DNO_CUDA=$(usex !cuda)
-DNO_REGRESSION=1 # They don't work with certain settings
- -DNO_EXAMPLES=$(usex !examples)
- -DNO_TUTORIALS=$(usex !tutorials)
+ -DNO_EXAMPLES=1 # Not needed.
+ -DNO_TUTORIALS=1 # They install illegally. Need to find a better solution.
-DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"