summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-13 10:18:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-13 12:16:13 +0200
commit6d072e2cf48417d46afd4a566230fda1f9aafd6f (patch)
tree0b637d137b073aa40505a909acc0e1e3bbd456ea /media-libs/opusfile/opusfile-0.8.ebuild
parentmedia-libs/fontconfig: Removed old. (diff)
downloadgentoo-6d072e2cf48417d46afd4a566230fda1f9aafd6f.tar.gz
gentoo-6d072e2cf48417d46afd4a566230fda1f9aafd6f.tar.bz2
gentoo-6d072e2cf48417d46afd4a566230fda1f9aafd6f.zip
media-libs/opusfile: Bump to version 0.8
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/opusfile/opusfile-0.8.ebuild')
-rw-r--r--media-libs/opusfile/opusfile-0.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/opusfile/opusfile-0.8.ebuild b/media-libs/opusfile/opusfile-0.8.ebuild
new file mode 100644
index 000000000000..a1706b87abb1
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="http://www.opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc fixed-point +float +http libressl static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable fixed-point)\
+ $(use_enable float) \
+ $(use_enable http) \
+ $(use_enable static-libs static)
+}