summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/oyranos/oyranos-0.9.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/oyranos/oyranos-0.9.5.ebuild')
-rw-r--r--media-libs/oyranos/oyranos-0.9.5.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/media-libs/oyranos/oyranos-0.9.5.ebuild b/media-libs/oyranos/oyranos-0.9.5.ebuild
new file mode 100644
index 000000000000..183f150f970d
--- /dev/null
+++ b/media-libs/oyranos/oyranos-0.9.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic cmake-utils cmake-multilib
+
+DESCRIPTION="Colour management system allowing to share various settings across applications and services"
+HOMEPAGE="http://www.oyranos.org/"
+SRC_URI="mirror://sourceforge/oyranos/Oyranos/Oyranos%200.9/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="X cairo cups doc exif fltk qt4 raw test"
+
+RDEPEND="
+ || (
+ =app-admin/elektra-0.7*:0=[${MULTILIB_USEDEP}]
+ >=app-admin/elektra-0.8.4:0=[${MULTILIB_USEDEP}]
+ )
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ >=dev-libs/yajl-2.0.4-r1[${MULTILIB_USEDEP}]
+ media-libs/icc-profiles-basiccolor-printing2009
+ media-libs/icc-profiles-openicc
+ >=media-libs/lcms-2.5:2[${MULTILIB_USEDEP}]
+ >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}]
+ >=media-libs/libXcm-0.5.3[${MULTILIB_USEDEP}]
+ cairo? ( >=x11-libs/cairo-1.12.14-r4[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-1.7.1-r1[${MULTILIB_USEDEP}] )
+ exif? ( >=media-gfx/exiv2-0.23-r2:=[${MULTILIB_USEDEP}] )
+ fltk? ( x11-libs/fltk:1 )
+ qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
+ raw? ( >=media-libs/libraw-0.15.4[${MULTILIB_USEDEP}] )
+ X? ( >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
+ >=x11-libs/libXinerama-1.1.3[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )"
+
+DOCS="AUTHORS ChangeLog README"
+RESTRICT="test"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/oyranos-config
+)
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/oyranos/oyranos_version.h
+)
+
+CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindFltk FindXcm FindCUPS"
+
+src_prepare() {
+ einfo remove bundled libs
+ rm -rf elektra* yajl || die
+
+ epatch "${FILESDIR}/${PN}"-0.9.5-buildsystem-r1.patch
+
+ if use fltk ; then
+ #src/examples does not include fltk flags
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags)
+ fi
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DLIB_SUFFIX=${libdir#lib}
+
+ $(usex cairo -DWANT_CAIRO=1 "")
+ $(usex cups -DWANT_CUPS=1 "")
+ $(usex doc -DWANT_HTML=1 "")
+ $(usex exif -DWANT_EXIV2=1 "")
+ $(usex raw -DWANT_LIBRAW=1 "")
+ $(usex X -DWANT_X11=1 "")
+
+ # only used in programs
+ $(multilib_native_usex fltk -DWANT_FLTK=1 "")
+ $(multilib_native_usex qt4 -DWANT_QT4=1 "")
+ )
+
+ cmake-utils_src_configure
+}