summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-11-04 23:25:41 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-11-04 23:26:03 +1100
commit8bde2c6895dd6bef4c5d7bee86f584b19fcbc080 (patch)
tree008097eacd346696d46aafff1fd99191e3c61508 /media-libs/qt-gstreamer/files
parentnet-misc/knemo: remove old (diff)
downloadgentoo-8bde2c6895dd6bef4c5d7bee86f584b19fcbc080.tar.gz
gentoo-8bde2c6895dd6bef4c5d7bee86f584b19fcbc080.tar.bz2
gentoo-8bde2c6895dd6bef4c5d7bee86f584b19fcbc080.zip
media-libs/qt-gstreamer: backport patch from upstream solving build failure with >=media-libs/gstreamer-1.5
Gentoo-bug: 564652 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs/qt-gstreamer/files')
-rw-r--r--media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-gstreamer15.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-gstreamer15.patch b/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-gstreamer15.patch
new file mode 100644
index 000000000000..6e875f678c2d
--- /dev/null
+++ b/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-gstreamer15.patch
@@ -0,0 +1,39 @@
+From e2ca8094aa8d0eac1c3a98df66fe94ce0c754088 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Manuel=20Santamar=C3=ADa?= <panfaust@gmail.com>
+Date: Fri, 2 Oct 2015 15:00:29 +0300
+Subject: Fix compilation with GStreamer >= 1.5.1
+
+apply gstreamer pkg-config definitions To ensure gstreamer builds correctly,
+pick up its cflags in FindGstreamer and apply them to the build as definitions
+
+https://lists.ubuntu.com/archives/kubuntu-devel/2015-August/009819.html
+
+https://bugzilla.gnome.org/show_bug.cgi?id=751382
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4d3e7dd..5744015 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -106,6 +106,7 @@ find_package(GObject)
+ macro_log_feature(GOBJECT_FOUND "GObject" "Required to build QtGLib" "http://www.gtk.org/" TRUE)
+
+ set(CMAKE_REQUIRED_INCLUDES ${QTGSTREAMER_INCLUDES})
++add_definitions(${GSTREAMER_DEFINITIONS})
+ include(CheckCXXSourceCompiles)
+ check_cxx_source_compiles("
+ #include <QtCore/QtGlobal>
+diff --git a/cmake/modules/FindGStreamer.cmake b/cmake/modules/FindGStreamer.cmake
+index dab91ac..fe6cde1 100644
+--- a/cmake/modules/FindGStreamer.cmake
++++ b/cmake/modules/FindGStreamer.cmake
+@@ -36,6 +36,7 @@ if (PKG_CONFIG_FOUND)
+ exec_program(${PKG_CONFIG_EXECUTABLE}
+ ARGS --variable pluginsdir gstreamer-${GSTREAMER_ABI_VERSION}
+ OUTPUT_VARIABLE PKG_GSTREAMER_PLUGIN_DIR)
++ set(GSTREAMER_DEFINITIONS ${PKG_GSTREAMER_CFLAGS})
+ endif()
+
+ find_library(GSTREAMER_LIBRARY
+--
+cgit v0.10.2
+