summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/quvi/files/quvi-0.9.1-automagic.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/quvi/files/quvi-0.9.1-automagic.patch')
-rw-r--r--media-libs/quvi/files/quvi-0.9.1-automagic.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/quvi/files/quvi-0.9.1-automagic.patch b/media-libs/quvi/files/quvi-0.9.1-automagic.patch
new file mode 100644
index 000000000000..0f011eb2fe7c
--- /dev/null
+++ b/media-libs/quvi/files/quvi-0.9.1-automagic.patch
@@ -0,0 +1,47 @@
+--- quvi-0.9.1/configure.ac
++++ quvi-0.9.1/configure.ac
+@@ -54,22 +54,30 @@
+ PKG_CHECK_MODULES([gobject], [gobject-2.0 >= 2.24])
+ PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.24])
+
+-PKG_CHECK_MODULES([json_glib], [json-glib-1.0 >= 0.12],
+- [have_json_glib=yes
+- AC_DEFINE([HAVE_JSON_GLIB], [1], [Define to json-glib package])
+- ],
+- [have_json_glib=no
+- AC_MSG_NOTICE([json-glib 0.12+ not found, building without json output])
+- ])
++AC_ARG_ENABLE([json],
++ AS_HELP_STRING([--disable-json], [Disable support for JSON output]))
++AS_IF([test "x$enable_json" != "xno"], [
++ PKG_CHECK_MODULES([json_glib], [json-glib-1.0 >= 0.12],
++ [have_json_glib=yes
++ AC_DEFINE([HAVE_JSON_GLIB], [1], [Define to json-glib package])
++ ],
++ [have_json_glib=no
++ AC_MSG_ERROR([json-glib 0.12+ not found])
++ ])
++])
+ AM_CONDITIONAL([HAVE_JSON_GLIB], [test x"$have_json_glib" = "xyes"])
+
+-PKG_CHECK_MODULES([libxml], [libxml-2.0 >= 2.7.8],
+- [have_libxml=yes
+- AC_DEFINE([HAVE_LIBXML], [1], [Define to libxml package])
+- ],
+- [have_libxml=no
+- AC_MSG_NOTICE([libxml 2.7.8+ not found, building without xml output])
+- ])
++AC_ARG_ENABLE([xml],
++ AS_HELP_STRING([--disable-xml], [Disable support for XML output]))
++AS_IF([test "x$enable_xml" != "xno"], [
++ PKG_CHECK_MODULES([libxml], [libxml-2.0 >= 2.7.8],
++ [have_libxml=yes
++ AC_DEFINE([HAVE_LIBXML], [1], [Define to libxml package])
++ ],
++ [have_libxml=no
++ AC_MSG_ERROR([libxml 2.7.8+ not found])
++ ])
++])
+ AM_CONDITIONAL([HAVE_LIBXML], [test x"$have_libxml" = "xyes"])
+
+ # Checks for header files.