summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-03-07 08:24:42 +0100
committerMichael Weber <xmw@gentoo.org>2017-03-07 08:24:42 +0100
commit9cf97971322a046a0b99b0115bf16b496b6c8c2f (patch)
tree33105e4d2df9cb7a637cf565b262a1d8e4c350eb /media-libs/raspberrypi-userland-bin
parentmedia-libs/raspberrypi-userland-bin: Remove old version. (diff)
downloadgentoo-9cf97971322a046a0b99b0115bf16b496b6c8c2f.tar.gz
gentoo-9cf97971322a046a0b99b0115bf16b496b6c8c2f.tar.bz2
gentoo-9cf97971322a046a0b99b0115bf16b496b6c8c2f.zip
media-libs/raspberrypi-userland-bin: Version bump.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-libs/raspberrypi-userland-bin')
-rw-r--r--media-libs/raspberrypi-userland-bin/Manifest1
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/Manifest b/media-libs/raspberrypi-userland-bin/Manifest
index c2488b0404bb..b20981a89824 100644
--- a/media-libs/raspberrypi-userland-bin/Manifest
+++ b/media-libs/raspberrypi-userland-bin/Manifest
@@ -1 +1,2 @@
DIST raspberrypi-firmware-1.20160309.tar.gz 115673896 SHA256 ead0e82b930fdeed9636a6d2d6e07b2512b5f36de3c902da5beaa9328708e181 SHA512 30a6396ef52355c6f6404354645e8d0f5bbf70332b0e1661dfa8ef3456154d07e105d3b7b5bd64efb3e7397fa2fb8c36de1aa78040dc4118060b26949c2ab884 WHIRLPOOL 19a2a28e7dc1403958f12338b5029187bb752f1367f9a46e217b3d91b098960f1cf75efb3610defe3bb2f521559019453cf50a52def3abb9c1ac61419b8ea328
+DIST raspberrypi-firmware-1.20170303.tar.gz 118888867 SHA256 ee8758d7e63c8fea7c8b7b476ff1c09f9591c74349b7751036a78ae5b88eca36 SHA512 cb0015fcaa607039db2ff40cadcfcafd0cf2ec7dd1df47f38414540fb1f86d626648bf6403989007895b0617c13ff4ec233a7b1987986224c09a8209e7732501 WHIRLPOOL 117b7fd58936ee938653fac063d200ae1a83195ebae1eb847fb0036d78932ed052d788fc1311463d2b9a6b5c7bb4c2678caf7ec71d9c147759636e91c532afeb
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild
new file mode 100644
index 000000000000..f011422bc21c
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20170303.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib vcs-snapshot
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_P="raspberrypi-firmware-${PV}"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="binchecks"
+
+src_prepare() {
+ rm {,hardfp/}opt/vc/LICENCE || die
+}
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+ into /opt
+ dobin bin/*
+ dobin sbin/*
+ insopts -m 0755
+ insinto "/opt/vc/$(get_libdir)"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ insinto /usr/share/doc/${PF}/examples
+ doins -r src/hello_pi
+ fi
+}