summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-16 19:33:23 +0000
committerSam James <sam@gentoo.org>2021-02-16 19:33:23 +0000
commitae0419fa055fc278fb7d9763587ac7c54e854554 (patch)
treebf53584f97c6d62a0584728c94a9096035974c5a /media-libs/raspberrypi-userland
parentRevert "media-libs/raspberrypi-userland: cleanup old" (diff)
downloadgentoo-ae0419fa055fc278fb7d9763587ac7c54e854554.tar.gz
gentoo-ae0419fa055fc278fb7d9763587ac7c54e854554.tar.bz2
gentoo-ae0419fa055fc278fb7d9763587ac7c54e854554.zip
media-libs/raspberrypi-userland: port to EAPI 7 for legacy version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/raspberrypi-userland')
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
index ddbbd294d3a3..8c43fe24aa99 100644
--- a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Raspberry Pi userspace tools and libraries"
HOMEPAGE="https://github.com/raspberrypi/userland"
@@ -11,7 +11,6 @@ HOMEPAGE="https://github.com/raspberrypi/userland"
if [[ ${PV} == 9999* ]]; then
inherit git-2
EGIT_REPO_URI="https://github.com/${PN/-//}.git"
- SRC_URI=""
else
GIT_COMMIT="dff5760"
SRC_URI="https://github.com/raspberrypi/userland/tarball/${GIT_COMMIT} -> ${P}.tar.gz"
@@ -46,15 +45,19 @@ src_unpack() {
}
src_prepare() {
+ default
+
# init script for Debian, not useful on Gentoo
sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
# wayland egl support
- epatch "${FILESDIR}"/next-resource-handle.patch
+ eapply "${FILESDIR}"/next-resource-handle.patch
+
+ cmake_src_prepare
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# provide OpenGL ES v1 according to https://github.com/raspberrypi/firmware/issues/78
dosym libGLESv2.so /opt/vc/lib/libGLESv1_CM.so