summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-01-18 10:47:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-01-18 10:47:53 +0200
commit8305f0c6cd0ce8cb5ac0f2d92569acce36a5cc0a (patch)
tree9ee596ab927d65aee5bf72f3431ad7c09f7bc9ef /media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild
parentnet-analyzer/wireshark: Drop upstream patch (diff)
downloadgentoo-8305f0c6cd0ce8cb5ac0f2d92569acce36a5cc0a.tar.gz
gentoo-8305f0c6cd0ce8cb5ac0f2d92569acce36a5cc0a.tar.bz2
gentoo-8305f0c6cd0ce8cb5ac0f2d92569acce36a5cc0a.zip
media-libs/rlottie: bump to 2020-01-10 commit
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild')
-rw-r--r--media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild b/media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild
new file mode 100644
index 000000000000..50f5ab3f029d
--- /dev/null
+++ b/media-libs/rlottie/rlottie-0.0.1_pre20200110.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+MY_COMMIT="f6fc61f214945ac9961ba49fdfc9a3d3336e999b"
+
+DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
+HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
+SRC_URI="https://github.com/Samsung/rlottie/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD FTL JSON LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/rlottie-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/rlottie-0.0.1_pre20190920-disable-werror.patch )
+
+src_configure() {
+ local emesonargs=(
+ -D example=false
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
+ eninja test
+}