summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-12-09 19:06:04 +0100
committerPacho Ramos <pacho@gentoo.org>2020-12-09 19:09:40 +0100
commit30d896b31ad2e5725469f02e932b0362b9f13397 (patch)
treeccdc353eaed134209ac945331cab2e210131c5fe /media-libs/sbc
parentnet-mail/b4: bump to 0.6.1 (diff)
downloadgentoo-30d896b31ad2e5725469f02e932b0362b9f13397.tar.gz
gentoo-30d896b31ad2e5725469f02e932b0362b9f13397.tar.bz2
gentoo-30d896b31ad2e5725469f02e932b0362b9f13397.zip
media-libs/sbc: Bump to 1.5
Thanks-to: Joakim Tjernlund Closes: https://bugs.gentoo.org/759073 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-libs/sbc')
-rw-r--r--media-libs/sbc/Manifest1
-rw-r--r--media-libs/sbc/sbc-1.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/sbc/Manifest b/media-libs/sbc/Manifest
index 95b5e0471cad..41721d26859d 100644
--- a/media-libs/sbc/Manifest
+++ b/media-libs/sbc/Manifest
@@ -1 +1,2 @@
DIST sbc-1.4.tar.xz 250656 BLAKE2B a5b59a0ac209b44843af49e63f7b6a6b397b3905f0efc52c18a3b92785d297d39dad80f5b124e97c50a9535f892f1451bf0a2945ba223a522eafbcad46eaad9d SHA512 f35250c202034e93ce4046d29883d76b162164d42fb59e6af8ff5e57f197244238f5f8087309cef2d44755c179e7f0869cf096735c8de510b1ac7e0f6c29d84f
+DIST sbc-1.5.tar.xz 264472 BLAKE2B 421a4cb5ab0e282255f8bdb810384e0a4d6d66835869489c22d51d2a0cabd7ef834bef3756ff887b9d9166dcfe88f4d661c26cb804e2868fb6106cc4886f9dcc SHA512 0243586188acede595317f2afbfdb41be5850d2a6133c374edbe5cbcf59a2a0fd4570d0b8f2d13ce9637ce48b2f1910c3e4ab1c0354dbf273ee67b09db8c4915
diff --git a/media-libs/sbc/sbc-1.5.ebuild b/media-libs/sbc/sbc-1.5.ebuild
new file mode 100644
index 000000000000..65d68e49819c
--- /dev/null
+++ b/media-libs/sbc/sbc-1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="Audio codec to connect bluetooth HQ audio devices as headphones or loudspeakers"
+HOMEPAGE="https://git.kernel.org/?p=bluetooth/sbc.git"
+SRC_URI="https://www.kernel.org/pub/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}