summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-02 17:48:21 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-02 17:49:38 +0200
commit45f55b304021df879ccc919c6bdb5ec58e9ae513 (patch)
tree968febcd57d1283ff85bae2059b187bf43528e30 /media-libs/sdl-image/sdl-image-1.2.12-r2.ebuild
parentgnome-extra/synapse: drop optional zeitgeist support (diff)
downloadgentoo-45f55b304021df879ccc919c6bdb5ec58e9ae513.tar.gz
gentoo-45f55b304021df879ccc919c6bdb5ec58e9ae513.tar.bz2
gentoo-45f55b304021df879ccc919c6bdb5ec58e9ae513.zip
media-libs/sdl-image: Add := on media-libs/libwebp
Add a subslot rebuild operator on media-libs/libwebp. This package has incompatible ABI changes since last sdl-image bump, and upstream apparently fails to bump SONAME.
Diffstat (limited to 'media-libs/sdl-image/sdl-image-1.2.12-r2.ebuild')
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.12-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/sdl-image/sdl-image-1.2.12-r2.ebuild b/media-libs/sdl-image/sdl-image-1.2.12-r2.ebuild
new file mode 100644
index 000000000000..6a9bc4aa1f1a
--- /dev/null
+++ b/media-libs/sdl-image/sdl-image-1.2.12-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib-minimal
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="image file loading library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_image/"
+SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.7-r1:0[${MULTILIB_USEDEP}] )
+ webp? ( >=media-libs/libwebp-0.3.0:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-jpg-shared \
+ --disable-png-shared \
+ --disable-tif-shared \
+ --disable-webp-shared \
+ $(use_enable static-libs static) \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ $(use_enable tiff tif) \
+ $(use_enable png) \
+ $(use_enable webp) \
+ --enable-bmp \
+ --enable-lbm \
+ --enable-pcx \
+ --enable-pnm \
+ --enable-tga \
+ --enable-xcf \
+ --enable-xpm \
+ --enable-xv
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ dobin .libs/showimage
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ use static-libs || prune_libtool_files --all
+}