summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sg/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sg/files')
-rw-r--r--media-libs/sg/files/1.4-doc.patch20
-rw-r--r--media-libs/sg/files/1.4-opengl.patch98
2 files changed, 118 insertions, 0 deletions
diff --git a/media-libs/sg/files/1.4-doc.patch b/media-libs/sg/files/1.4-doc.patch
new file mode 100644
index 000000000000..cfc1b21b20cb
--- /dev/null
+++ b/media-libs/sg/files/1.4-doc.patch
@@ -0,0 +1,20 @@
+diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
+index 3ee562c..7f424e8 100644
+--- a/doc/doxygen/Makefile.am
++++ b/doc/doxygen/Makefile.am
+@@ -29,13 +29,11 @@
+ ## Author: Michael Holst
+ ## ###########################################################################
+
+-docdir = @prefix@/doc/sg
+-
+ doc_DATA = sg_doc
+
+ sg_doc:
+ $(doxygen_path) $(top_srcdir)/doc/doxygen/sg.dox
+
+ install-docDATA:
+- mkdir -p $(docdir)
+- cp -r ../api $(docdir)/
++ mkdir -p $(DESTDIR)/@docdir@
++ cp -r ../api $(DESTDIR)/@docdir@/
diff --git a/media-libs/sg/files/1.4-opengl.patch b/media-libs/sg/files/1.4-opengl.patch
new file mode 100644
index 000000000000..f6b32cf1d286
--- /dev/null
+++ b/media-libs/sg/files/1.4-opengl.patch
@@ -0,0 +1,98 @@
+diff --git a/configure.ac b/configure.ac
+index 68ff24a..a2cd6b5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -844,9 +844,6 @@ AC_OUTPUT([
+
+ src/base/Makefile
+
+- src/gl/Makefile
+- src/glu/Makefile
+- src/glw/Makefile
+ src/ogl/Makefile
+ src/vgl/Makefile
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index ad9562f..7d5173c 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -35,5 +35,5 @@
+ AUTOMAKE_OPTIONS = no-dependencies
+ SUFFIXES = .y .l .H .h .m .C .cc .c .f .java .o
+ always_built_SUBDIRS = ogl vgl
+-SUBDIRS = base @gl@ @glu@ @glw@ $(always_built_SUBDIRS) aaa_inc aaa_lib .
++SUBDIRS = base $(always_built_SUBDIRS) aaa_inc aaa_lib .
+
+diff --git a/src/aaa_inc/GL/Makefile.am b/src/aaa_inc/GL/Makefile.am
+index 10efb6b..0d5b8b7 100644
+--- a/src/aaa_inc/GL/Makefile.am
++++ b/src/aaa_inc/GL/Makefile.am
+@@ -37,27 +37,6 @@ SUFFIXES = .y .l .H .h .m .C .cc .c .f .java .o
+ always_built_SUBDIRS =
+ SUBDIRS = $(always_built_SUBDIRS) .
+
+-if BUILD_GL
+-GL_HEADS = gl.h glx.h osmesa.h wmesa.h xmesa.h
+-else
+-GL_HEADS =
+-endif
+-
+-if BUILD_GLU
+-GLU_HEADS = glu.h
+-else
+-GLU_HEADS =
+-endif
+-
+-if BUILD_GLW
+-GLW_HEADS = GLwDrawA.h
+-else
+-GLW_HEADS =
+-endif
+-
+-includedir = ${prefix}/include/GL
+-include_HEADERS = ${GL_HEADS} ${GLU_HEADS} ${GLW_HEADS}
+-
+ distclean-local: clean-local
+
+ clean-local:
+diff --git a/src/aaa_lib/Makefile.am b/src/aaa_lib/Makefile.am
+index bb93779..0512c45 100644
+--- a/src/aaa_lib/Makefile.am
++++ b/src/aaa_lib/Makefile.am
+@@ -41,32 +41,16 @@ BASE_LIBS = ../base/libbase.la
+ OGL_LIBS = ../ogl/libogl.la
+ VGL_LIBS = ../vgl/libvgl.la
+
+-GL_LIBS = ../gl/libGL.la
+-if BUILD_GL
+-LIBGL = libGL.la
+-else
+-LIBGL =
+-endif
++GL_LIBS = ${libdir}/libGL.la
+
+-GLU_LIBS = ../glu/libGLU.la
+-if BUILD_GLU
+-LIBGLU = libGLU.la
+-else
+-LIBGLU =
+-endif
++GLU_LIBS = ${libdir}/libGLU.la
+
+-GLW_LIBS = ../glw/libGLw.la
+-if BUILD_GLW
+-LIBGLW = libGLw.la
+-else
+-LIBGLW =
+-endif
++GLW_LIBS = ${libdir}/libGLw.la
+
+-libdir = ${prefix}/lib
+ lib_LTLIBRARIES = libsg.la ${LIBGL} ${LIBGLU} ${LIBGLW}
+
+ libsg_la_SOURCES =
+-libsg_la_LIBADD = ${BASE_LIBS} ${OGL_LIBS} ${VGL_LIBS}
++libsg_la_LIBADD = ${BASE_LIBS} ${OGL_LIBS} ${VGL_LIBS} -lGL -lGLU -lGLw -lXm -lmaloc -lXaw
+ libsg_la_LDFLAGS = -version-info ${FETK_VERSION}
+
+ libGL_la_SOURCES =