summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sge')
-rw-r--r--media-libs/sge/Manifest1
-rw-r--r--media-libs/sge/files/sge-030809-build.patch123
-rw-r--r--media-libs/sge/files/sge-030809-cmap.patch28
-rw-r--r--media-libs/sge/files/sge-030809-freetype.patch25
-rw-r--r--media-libs/sge/metadata.xml8
-rw-r--r--media-libs/sge/sge-030809.ebuild56
6 files changed, 241 insertions, 0 deletions
diff --git a/media-libs/sge/Manifest b/media-libs/sge/Manifest
new file mode 100644
index 000000000000..9a436f4e2348
--- /dev/null
+++ b/media-libs/sge/Manifest
@@ -0,0 +1 @@
+DIST sge030809.tar.gz 251698 SHA256 25cfbe59ab99647254e69d25984707045492c2a5d1b15f27d999d0284a7110fc SHA512 59144d573f254cc451a22a2d60ba68c7d9437b5095f63fc7ec36c21c3caf7580c5365267a004e08b9d08cf187a59ddefb76a5829f4a6aa1ff4d45f7d044bb2fb WHIRLPOOL 627a67c5092fe1e3c313b9fa3588ad28f2d10a9dccbce2705847274f33195579f2e98e39f2ef1c7a82c80d8cb32a02ebf31ee9822f0975de3de19b4ce427db0d
diff --git a/media-libs/sge/files/sge-030809-build.patch b/media-libs/sge/files/sge-030809-build.patch
new file mode 100644
index 000000000000..5b277a0a6b08
--- /dev/null
+++ b/media-libs/sge/files/sge-030809-build.patch
@@ -0,0 +1,123 @@
+--- Makefile.orig 2006-03-29 00:08:39.000000000 -0500
++++ Makefile 2006-03-29 00:09:36.000000000 -0500
+@@ -2,7 +2,7 @@
+
+ include Makefile.conf
+
+-CFLAGS += $(SGE_CFLAGS) -fPIC $(FT_CFLAGS)
++CXXFLAGS += $(SGE_CFLAGS) -fPIC $(FT_CFLAGS)
+ LIBS =$(SGE_LIBS)
+
+ SGE_VER = 030809
+@@ -10,20 +10,26 @@
+
+ OBJECTS=sge_surface.o sge_primitives.o sge_tt_text.o sge_bm_text.o sge_misc.o sge_textpp.o sge_blib.o sge_rotation.o sge_collision.o sge_shape.o
+
+-all: config $(OBJECTS)
+- @ar rsc libSGE.a $(OBJECTS)
++SHARED_LIB=libSGE.so.$(API_VER)
++STATIC_LIB=libSGE.a
+
+-$(OBJECTS): %.o:%.cpp %.h #Each object depends on thier .cpp and .h file
+- $(CXX) $(CFLAGS) -c $<
++all: sge_config.h $(OBJECTS) $(SHARED_LIB) $(STATIC_LIB)
+
+-shared: all
+- $(CXX) $(CFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
++$(STATIC_LIB): $(OBJECTS)
++ $(AR) rsc libSGE.a $(OBJECTS)
+
+-shared-strip: shared
++$(OBJECTS): sge_config.h
++$(OBJECTS): %.o:%.cpp %.h #Each object depends on their .cpp and .h file
++ $(CXX) $(CXXFLAGS) -c $<
++
++$(SHARED_LIB): $(OBJECTS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
++
++shared-strip: $(SHARED_LIB)
+ @strip libSGE.so
+
+ # Building a dll... I have no idea how to do this, but it should be something like below.
+-dll: config $(OBJECTS)
++dll: sge_config.h $(OBJECTS)
+ dlltool --output-def SGE.def $(OBJECTS)
+ dllwrap --driver-name $(CXX) -o SGE.dll --def SGE.def --output-lib libSGE.a --dllname SGE.dll $(OBJECTS) $(LIBS)
+
+@@ -33,21 +39,22 @@
+ clean:
+ @rm -f *.o *.so *.a *.dll *.def
+
+-config:
+- @echo "/* SGE Config header (generated automatically) */" >sge_config.h
+- @echo "#define SGE_VER $(SGE_VER)" >>sge_config.h
++sge_config.h:
++ @echo "/* SGE Config header (generated automatically) */" >sge_config.h.tmp
++ @echo "#define SGE_VER $(SGE_VER)" >>sge_config.h.tmp
+ ifeq ($(C_COMP),y)
+- @echo "#define _SGE_C_AND_CPP" >>sge_config.h
++ @echo "#define _SGE_C_AND_CPP" >>sge_config.h.tmp
+ endif
+ ifeq ($(USE_FT),n)
+- @echo "#define _SGE_NOTTF" >>sge_config.h
++ @echo "#define _SGE_NOTTF" >>sge_config.h.tmp
+ endif
+ ifeq ($(USE_IMG),y)
+- @echo "#define _SGE_HAVE_IMG" >>sge_config.h
++ @echo "#define _SGE_HAVE_IMG" >>sge_config.h.tmp
+ endif
+ ifeq ($(NO_CLASSES),y)
+- @echo "#define _SGE_NO_CLASSES" >>sge_config.h
++ @echo "#define _SGE_NO_CLASSES" >>sge_config.h.tmp
+ endif
++ mv sge_config.h.tmp sge_config.h
+
+ ifneq ($(QUIET),y)
+ @echo "== SGE r$(SGE_VER)"
+@@ -70,13 +77,13 @@
+ @echo ""
+ endif
+
+-install: shared
+- @mkdir -p $(PREFIX_H)
+- install -c -m 644 sge*.h $(PREFIX_H)
+- @mkdir -p $(PREFIX)/lib
+- install -c -m 644 libSGE.a $(PREFIX)/lib
+- install -c libSGE.so $(PREFIX)/lib/libSGE.so.$(API_VER).$(SGE_VER)
+- @cd $(PREFIX)/lib;\
++install: $(SHARED_LIB) $(STATIC_LIB)
++ @mkdir -p $(DESTDIR)$(PREFIX_H)
++ install -c -m 644 sge*.h $(DESTDIR)$(PREFIX_H)
++ @mkdir -p $(DESTDIR)$(PREFIX)/lib
++ install -c -m 644 $(STATIC_LIB) $(DESTDIR)$(PREFIX)/lib
++ install -c libSGE.so $(DESTDIR)$(PREFIX)/lib/libSGE.so.$(API_VER).$(SGE_VER)
++ @cd $(DESTDIR)$(PREFIX)/lib;\
+ ln -sf libSGE.so.$(API_VER).$(SGE_VER) libSGE.so.$(API_VER);\
+ ln -sf libSGE.so.$(API_VER) libSGE.so
+ @echo "** Headerfiles installed in $(PREFIX_H)"
+--- Makefile.conf.orig 2006-03-29 00:08:39.000000000 -0500
++++ Makefile.conf 2006-03-29 00:08:39.000000000 -0500
+@@ -11,6 +11,7 @@
+ # Compilers (C and C++)
+ CC=gcc
+ CXX=g++
++AR=ar
+
+ # Make sure sdl-config is available
+ HAVE_SDL =$(shell if (sdl-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
+@@ -25,11 +26,13 @@
+ PREFIX_H =$(shell sdl-config --prefix)/include/SDL
+
+ # Flags passed to the compiler
+-CFLAGS =-Wall -O3 -ffast-math
++CXXFLAGS ?=-O3 -ffast-math
+ SGE_CFLAGS =$(shell sdl-config --cflags)
+ # Uncomment to make some more optimizations
+-#CFLAGS =-Wall -O9 -ffast-math -march=i686
++#CXXFLAGS =-O9 -ffast-math -march=i686
+
++# Spit out warnings
++CXXFLAGS += -Wall
+
+ # Libs config
+ SGE_LIBS =$(shell sdl-config --libs) -lstdc++
diff --git a/media-libs/sge/files/sge-030809-cmap.patch b/media-libs/sge/files/sge-030809-cmap.patch
new file mode 100644
index 000000000000..c03396e1fb8b
--- /dev/null
+++ b/media-libs/sge/files/sge-030809-cmap.patch
@@ -0,0 +1,28 @@
+http://bugs.gentoo.org/33296#26
+
+patch by Steve <steviedizzle@gmail.com>
+
+explanation:
+It changes the 16bit integers for setting and clearing collision maps to 32bit
+because if the surface is too large the program will segfault.
+
+--- sge030809/sge_collision.cpp
++++ sge030809/sge_collision.cpp
+@@ -336,7 +336,7 @@
+ void sge_unset_cdata(sge_cdata *cd, Sint16 x, Sint16 y, Sint16 w, Sint16 h)
+ {
+ Uint8 *map=cd->map;
+- Sint16 offs,len;
++ Sint32 offs,len;
+ int i,n=0;
+
+ offs=y*cd->w + x;
+@@ -365,7 +365,7 @@
+ void sge_set_cdata(sge_cdata *cd, Sint16 x, Sint16 y, Sint16 w, Sint16 h)
+ {
+ Uint8 *map=cd->map;
+- Sint16 offs,len;
++ Sint32 offs,len;
+ int i,n=0;
+
+ offs=y*cd->w + x;
diff --git a/media-libs/sge/files/sge-030809-freetype.patch b/media-libs/sge/files/sge-030809-freetype.patch
new file mode 100644
index 000000000000..7b638e4100f9
--- /dev/null
+++ b/media-libs/sge/files/sge-030809-freetype.patch
@@ -0,0 +1,25 @@
+--- sge_tt_text.cpp
++++ sge_tt_text.cpp
+@@ -36,10 +36,9 @@
+ #include "sge_textpp.h"
+
+ #ifndef _SGE_NOTTF
+-#include <freetype/freetype.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
+-#include <freetype/internal/ftobjs.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
++#include FT_OUTLINE_H
+
+ /* The structure used to hold glyph information (cached) */
+ struct glyph {
+@@ -294,7 +293,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = _sge_library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;
diff --git a/media-libs/sge/metadata.xml b/media-libs/sge/metadata.xml
new file mode 100644
index 000000000000..2f8b9cdd638d
--- /dev/null
+++ b/media-libs/sge/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="image">enable sdl-image support</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-libs/sge/sge-030809.ebuild b/media-libs/sge/sge-030809.ebuild
new file mode 100644
index 000000000000..6373a4bd07ad
--- /dev/null
+++ b/media-libs/sge/sge-030809.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+MY_P="sge${PV}"
+DESCRIPTION="Graphics extensions library for SDL"
+HOMEPAGE="http://www.etek.chalmers.se/~e8cal1/sge/"
+SRC_URI="http://www.etek.chalmers.se/~e8cal1/sge/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86 ~x86-fbsd"
+IUSE="doc examples image truetype"
+
+DEPEND="media-libs/libsdl
+ image? ( media-libs/sdl-image )
+ truetype? ( >=media-libs/freetype-2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-freetype.patch \
+ "${FILESDIR}"/${P}-cmap.patch
+ sed -i "s:\$(PREFIX)/lib:\$(PREFIX)/$(get_libdir):" Makefile || die
+ sed -i \
+ -e '/^CC=/d' \
+ -e '/^CXX=/d' \
+ -e '/^AR=/d' \
+ Makefile.conf || die
+ tc-export CC CXX AR
+ # make sure the header gets regenerated everytime
+ rm -f sge_config.h
+}
+
+src_compile() {
+ emake \
+ USE_IMG=$(usex image y n) \
+ USE_FT=$(usex truetype y n)
+}
+
+src_install() {
+ DOCS="README Todo WhatsNew" \
+ default
+
+ use doc && dohtml docs/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}