summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-07 21:35:22 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-07 21:39:40 +0200
commita44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7 (patch)
tree7a8b523adc69ddf1a95828373f1f8aa026b895c9 /media-libs/sge
parentx11-libs/gtk+: stable 2.24.32 for ia64, bug #660314 (diff)
downloadgentoo-a44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7.tar.gz
gentoo-a44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7.tar.bz2
gentoo-a44989ce5f8f8d92a61bc4c8fa5ffd6cb1d9dcb7.zip
media-libs/sge: Use pkg-config instead of freetype-config.
Closes: https://bugs.gentoo.org/655798 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'media-libs/sge')
-rw-r--r--media-libs/sge/files/sge-030809-build.patch8
-rw-r--r--media-libs/sge/files/sge-030809-freetype.patch4
-rw-r--r--media-libs/sge/files/sge-030809-freetype_pkgconfig.patch25
-rw-r--r--media-libs/sge/sge-030809.ebuild32
4 files changed, 52 insertions, 17 deletions
diff --git a/media-libs/sge/files/sge-030809-build.patch b/media-libs/sge/files/sge-030809-build.patch
index 5b277a0a6b08..4ded0888a7f3 100644
--- a/media-libs/sge/files/sge-030809-build.patch
+++ b/media-libs/sge/files/sge-030809-build.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2006-03-29 00:08:39.000000000 -0500
-+++ Makefile 2006-03-29 00:09:36.000000000 -0500
+--- a/Makefile
++++ b/Makefile
@@ -2,7 +2,7 @@
include Makefile.conf
@@ -95,8 +95,8 @@
ln -sf libSGE.so.$(API_VER).$(SGE_VER) libSGE.so.$(API_VER);\
ln -sf libSGE.so.$(API_VER) libSGE.so
@echo "** Headerfiles installed in $(PREFIX_H)"
---- Makefile.conf.orig 2006-03-29 00:08:39.000000000 -0500
-+++ Makefile.conf 2006-03-29 00:08:39.000000000 -0500
+--- a/Makefile.conf
++++ b/Makefile.conf
@@ -11,6 +11,7 @@
# Compilers (C and C++)
CC=gcc
diff --git a/media-libs/sge/files/sge-030809-freetype.patch b/media-libs/sge/files/sge-030809-freetype.patch
index 7b638e4100f9..f07ce98256a5 100644
--- a/media-libs/sge/files/sge-030809-freetype.patch
+++ b/media-libs/sge/files/sge-030809-freetype.patch
@@ -1,5 +1,5 @@
---- sge_tt_text.cpp
-+++ sge_tt_text.cpp
+--- a/sge_tt_text.cpp
++++ b/sge_tt_text.cpp
@@ -36,10 +36,9 @@
#include "sge_textpp.h"
diff --git a/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch b/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..ceb478f3d828
--- /dev/null
+++ b/media-libs/sge/files/sge-030809-freetype_pkgconfig.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/655798
+
+--- sge030809/Makefile.conf
++++ sge030809/Makefile.conf
+@@ -35,16 +35,16 @@
+ SGE_LIBS =$(shell sdl-config --libs) -lstdc++
+
+
+-# Is freetype-config available?
+-HAVE_FT =$(shell if (freetype-config --version) < /dev/null > /dev/null 2>&1; then echo "y"; else echo "n"; fi;)
++# Is freetype available?
++HAVE_FT =$(shell if pkg-config --exists freetype2 ; then echo "y"; else echo "n"; fi;)
+ ifeq ($(HAVE_FT),n)
+ USE_FT = n
+ endif
+
+ ifneq ($(USE_FT),n)
+ USE_FT = y
+- SGE_LIBS +=$(shell freetype-config --libs)
+- FT_CFLAGS =$(shell freetype-config --cflags)
++ SGE_LIBS +=$(shell pkg-config --libs freetype2)
++ FT_CFLAGS =$(shell pkg-config --cflags freetype2)
+ endif
+
+
diff --git a/media-libs/sge/sge-030809.ebuild b/media-libs/sge/sge-030809.ebuild
index 6bff1d0d2baf..159379bb02fd 100644
--- a/media-libs/sge/sge-030809.ebuild
+++ b/media-libs/sge/sge-030809.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils multilib toolchain-funcs
+EAPI=6
+inherit multilib toolchain-funcs
MY_P="sge${PV}"
DESCRIPTION="Graphics extensions library for SDL"
@@ -14,17 +14,24 @@ SLOT="0"
KEYWORDS="amd64 ~ia64 ppc x86 ~x86-fbsd"
IUSE="doc examples image truetype"
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
image? ( media-libs/sdl-image )
truetype? ( >=media-libs/freetype-2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-freetype.patch
+ "${FILESDIR}"/${P}-cmap.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
+)
+
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-freetype.patch \
- "${FILESDIR}"/${P}-cmap.patch
+ default
sed -i "s:\$(PREFIX)/lib:\$(PREFIX)/$(get_libdir):" Makefile || die
sed -i \
-e '/^CC=/d' \
@@ -43,10 +50,13 @@ src_compile() {
}
src_install() {
- DOCS="README Todo WhatsNew" \
- default
+ local DOCS=( README Todo WhatsNew )
+ default
- use doc && dohtml docs/*
+ if use doc ; then
+ docinto html
+ dodoc docs/*
+ fi
if use examples ; then
insinto /usr/share/doc/${PF}