summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-01-31 02:13:08 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-01-31 02:15:20 +0100
commitafb66845a9e3c30f419685657be626c4cccd323d (patch)
tree48c615ac13f3e8587a7d9df190b01715570d2fea /media-libs/simage
parentdev-util/idea-community: Version bump (diff)
downloadgentoo-afb66845a9e3c30f419685657be626c4cccd323d.tar.gz
gentoo-afb66845a9e3c30f419685657be626c4cccd323d.tar.bz2
gentoo-afb66845a9e3c30f419685657be626c4cccd323d.zip
media-libs/simage: bump to 1.8.0
1) switched from cmake-utils to cmake 2) updated homepage, src_uri and license 3) updated deps some updates used from the ebuild in waebbl overlay Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/simage')
-rw-r--r--media-libs/simage/Manifest1
-rw-r--r--media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch25
-rw-r--r--media-libs/simage/simage-1.8.0.ebuild82
3 files changed, 108 insertions, 0 deletions
diff --git a/media-libs/simage/Manifest b/media-libs/simage/Manifest
index dff8036465fa..ffa68c89f9b1 100644
--- a/media-libs/simage/Manifest
+++ b/media-libs/simage/Manifest
@@ -1 +1,2 @@
DIST simage-1.7.1-src.zip 4145907 BLAKE2B 99f5f5f46530c2600d47ab0bb080d69281447ee96a2bb9b63ebe5a5c56e235f34ca8bd97b0d6adedf061fe221a61d144d4ccce00123941a9c74d72b1f190030d SHA512 b3c81fa363cd570b3512cd2984f154b83876353ec389dc35afcac4e4ddf8d301eef5b0f8df93c38b9caa6afd81fbe53d3943ad05e041b77734f03c26d2e12867
+DIST simage-1.8.0.tar.gz 791151 BLAKE2B 0a5720c06501c8212b5a148ad790ff60d6d9fc507868a66d40dbe3b6b089e47dca21828fee96ef708a03651d02843c9e6b6db7856088ddf7e487b4b5eeafbccd SHA512 7070c845fc72094a97b1253d23a5f60f90e71dc6ed968c9c7da67e05660b05245a807fbdf0f592a1d459c7c3b725783c55f59f867182b11cb9ec40741d7ad58c
diff --git a/media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch b/media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch
new file mode 100644
index 000000000000..4dcc5994f360
--- /dev/null
+++ b/media-libs/simage/files/simage-1.8.0-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch
@@ -0,0 +1,25 @@
+From 1c0e3fb6deb9c3d3c1dd1d4940ffe8d71c2158c9 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Mon, 20 Jan 2020 18:45:10 +0100
+Subject: [PATCH] CMakeLists.txt: comment cpack.d inclusion
+
+Directory is not included in tarball and not needed on Gentoo.
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 775037a..e3deb01 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -627,4 +627,4 @@ install(EXPORT ${PROJECT_NAME}
+
+ # ############################################################################
+ # New CPACK section, please see the README file inside cpack.d directory.
+-add_subdirectory(cpack.d)
++#add_subdirectory(cpack.d)
+--
+2.25.0
+
diff --git a/media-libs/simage/simage-1.8.0.ebuild b/media-libs/simage/simage-1.8.0.ebuild
new file mode 100644
index 000000000000..8d8e6434e9ba
--- /dev/null
+++ b/media-libs/simage/simage-1.8.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Image and video texturing library"
+HOMEPAGE="https://github.com/coin3d/simage/"
+SRC_URI="https://github.com/coin3d/simage/archive/${P}.tar.gz"
+
+LICENSE="BSD-1"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="debug gif jpeg png qt5 sndfile test tiff vorbis"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sys-libs/zlib:=
+ gif? ( media-libs/giflib:= )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ )
+ sndfile? ( media-libs/libsndfile )
+ tiff? ( media-libs/tiff:0 )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( media-libs/libsndfile )
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.1-cmake-automagic-deps.patch"
+ # examples need to link against libsndfile unconditionally so either we could
+ # make the dep unconditional or not build the examples. i chose the latter way.
+ # btw, examples are not installed anyway, they are just compiled.
+ "${FILESDIR}/${PN}-1.7.1-disable-examples.patch"
+ "${FILESDIR}/${PN}-1.7.1-tests-conditional.patch"
+ "${FILESDIR}/${PN}-1.7.1-disable-gif-quantize-buffer.patch"
+ "${FILESDIR}/${P}-0001-CMakeLists.txt-comment-cpack.d-inclusion.patch"
+)
+
+DOCS=(AUTHORS ChangeLog NEWS README)
+
+src_configure() {
+ use debug && append-cppflags -DSIMAGE_DEBUG=1
+
+ local mycmakeargs=(
+ -DSIMAGE_AVIENC_SUPPORT=OFF # Windows only
+ -DSIMAGE_BUILD_SHARED_LIBS=ON
+ -DSIMAGE_CGIMAGE_SUPPORT=OFF # OS X only
+ -DSIMAGE_EPS_SUPPORT=ON
+ -DSIMAGE_GDIPLUS_SUPPORT=OFF # Windows only
+ -DSIMAGE_GIF_SUPPORT=$(usex gif)
+ -DSIMAGE_JASPER_SUPPORT=OFF
+ -DSIMAGE_JPEG_SUPPORT=$(usex jpeg)
+ -DSIMAGE_LIBSNDFILE_SUPPORT=$(usex sndfile)
+ -DSIMAGE_MPEG2ENC_SUPPORT=ON
+ -DSIMAGE_OGGVORBIS_SUPPORT=$(usex vorbis)
+ -DSIMAGE_PIC_SUPPORT=ON
+ -DSIMAGE_PNG_SUPPORT=$(usex png)
+ -DSIMAGE_QIMAGE_SUPPORT=$(usex qt5)
+ -DSIMAGE_QUICKTIME_SUPPORT=OFF # OS X only
+ -DSIMAGE_TIFF_SUPPORT=$(usex tiff)
+ -DSIMAGE_USE_QT5=ON
+ -DSIMAGE_RGB_SUPPORT=ON
+ -DSIMAGE_TGA_SUPPORT=ON
+ -DSIMAGE_XWD_SUPPORT=ON
+ -DTESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}