summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-10-02 10:45:04 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-10-02 10:45:22 +0200
commit3607d607b202eeeeefda7d42b96f86d646a97e16 (patch)
tree009d89b9038c9f1c0d45bce0fe76eee1af2e0a3a /media-libs/sratom
parentdev-libs/serd: added py3.9 to 0.30.6 (diff)
downloadgentoo-3607d607b202eeeeefda7d42b96f86d646a97e16.tar.gz
gentoo-3607d607b202eeeeefda7d42b96f86d646a97e16.tar.bz2
gentoo-3607d607b202eeeeefda7d42b96f86d646a97e16.zip
media-libs/sratom: bump to 0.6.6 + py3.9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/sratom')
-rw-r--r--media-libs/sratom/Manifest1
-rw-r--r--media-libs/sratom/sratom-0.6.6.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/sratom/Manifest b/media-libs/sratom/Manifest
index f6cfcb04b068..dfb564b1e3d4 100644
--- a/media-libs/sratom/Manifest
+++ b/media-libs/sratom/Manifest
@@ -1 +1,2 @@
DIST sratom-0.6.4.tar.bz2 339707 BLAKE2B acf29c7dd3c4e23bf20ef2811706abdd3543d0fc380183f7f419932c3178ff5e2f6d95c57bad2ef991dbc1e32c6e8a3645238c7b42dfd204942dbc4c05270652 SHA512 6462d8d33ed7ddaa2aea267fab14c9a15bfc077a4f8d26eb493be4c48c95d8dcec614f540bd82fe22aecca641771326a44d175c3991cd473ae371062c78aaac3
+DIST sratom-0.6.6.tar.bz2 347297 BLAKE2B 0cb1949486deb5e8f823b17c98fb415dc44b0cefece647b6c5b3646438736ee9c7afa617bb00a68d61a31c80f6e643758f48602f647655aa4b185b2cc5fff893 SHA512 ccc209af68a39c1a669ba694d250b292df2f588aeea2a9d1dfe54a23e31f032fcce1d99ebf9dd7cff80ce5aedd204c74e3ccc04d6cd239921cd3e443db83ed55
diff --git a/media-libs/sratom/sratom-0.6.6.ebuild b/media-libs/sratom/sratom-0.6.6.ebuild
new file mode 100644
index 000000000000..bce3d15203fb
--- /dev/null
+++ b/media-libs/sratom/sratom-0.6.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/serd
+ dev-libs/sord
+ media-libs/lv2
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README.md" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(multilib_native_usex doc --docs "") \
+ $(usex test --test "") \
+ $(usex static-libs --static "")
+}
+
+multilib_src_test() {
+ ./waf test || die
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+ default
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+ default
+}