summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-01-10 10:04:47 +1300
committerJoonas Niilola <juippis@gentoo.org>2021-01-10 05:42:07 +0200
commite4c4ea585e1c10c364abe3421811caf4a3ad2198 (patch)
treeea9a5c781ea4d77956e4cb17b6d941cfdd0e7be1 /media-libs/svt-av1
parentdev-libs/apr: Fixed build with sys-devel/autoconf-2.70 (diff)
downloadgentoo-e4c4ea585e1c10c364abe3421811caf4a3ad2198.tar.gz
gentoo-e4c4ea585e1c10c364abe3421811caf4a3ad2198.tar.bz2
gentoo-e4c4ea585e1c10c364abe3421811caf4a3ad2198.zip
media-libs/svt-av1: new package 0.8.6
The Scalable Video Technology for AV1 (SVT-AV1 Encoder and Decoder) is an AV1-compliant encoder/decoder library core. The SVT-AV1 encoder development is a work-in-progress targeting performance levels applicable to both VOD and Live encoding / transcoding video applications. The SVT-AV1 decoder implementation is targeting future codec research activities. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/17110 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/svt-av1')
-rw-r--r--media-libs/svt-av1/Manifest1
-rw-r--r--media-libs/svt-av1/metadata.xml18
-rw-r--r--media-libs/svt-av1/svt-av1-0.8.6.ebuild34
-rw-r--r--media-libs/svt-av1/svt-av1-9999.ebuild34
4 files changed, 87 insertions, 0 deletions
diff --git a/media-libs/svt-av1/Manifest b/media-libs/svt-av1/Manifest
new file mode 100644
index 000000000000..0f9abf8b935d
--- /dev/null
+++ b/media-libs/svt-av1/Manifest
@@ -0,0 +1 @@
+DIST svt-av1-0.8.6.tar.gz 6416120 BLAKE2B c30d3bfc2dba6d7964625c4505bb135aa335adf195df91ad058fb02496276cabdc651b09854a2d14136352a434e08f4974148e03e7d54bde0924d25a1c4524cd SHA512 07e7353e35bc581b23c71913e65f5fd27566f4bf1d317d474d57d5bb2b82f380f713a00be19bd3f703935da50f81f3abf1d4ae38fbdf253385edf423737c0543
diff --git a/media-libs/svt-av1/metadata.xml b/media-libs/svt-av1/metadata.xml
new file mode 100644
index 000000000000..ba30acda57ab
--- /dev/null
+++ b/media-libs/svt-av1/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>telans@posteo.de</email>
+ <name>Theo Anderson</name>
+ </maintainer>
+ <maintainer type="project">
+ <name>Proxy Maintainers</name>
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AOMediaCodec/SVT-AV1</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/svt-av1/svt-av1-0.8.6.ebuild b/media-libs/svt-av1/svt-av1-0.8.6.ebuild
new file mode 100644
index 000000000000..9bd9658e06a6
--- /dev/null
+++ b/media-libs/svt-av1/svt-av1-0.8.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Scalable Video Technology for AV1 (SVT-AV1 Encoder and Decoder)"
+HOMEPAGE="https://github.com/AOMediaCodec/SVT-AV1"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AOMediaCodec/SVT-AV1.git"
+else
+ SRC_URI="https://github.com/AOMediaCodec/SVT-AV1/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 -x86" # -x86: https://github.com/AOMediaCodec/SVT-AV1/issues/1231
+ S="${WORKDIR}/SVT-AV1-${PV}"
+fi
+
+# Also see "Alliance for Open Media Patent License 1.0"
+LICENSE="BSD-2 Apache-2.0 BSD ISC LGPL-2.1+ MIT"
+SLOT="0"
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ local mycmakeargs=(
+ # Tests require linking against https://github.com/Cidana-Developers/aom/tree/av1-normative ?
+ # undefined reference to `ifd_inspect'
+ # https://github.com/Cidana-Developers/aom/commit/cfc5c9e95bcb48a5a41ca7908b44df34ea1313c0
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake_src_configure
+}
diff --git a/media-libs/svt-av1/svt-av1-9999.ebuild b/media-libs/svt-av1/svt-av1-9999.ebuild
new file mode 100644
index 000000000000..9bd9658e06a6
--- /dev/null
+++ b/media-libs/svt-av1/svt-av1-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Scalable Video Technology for AV1 (SVT-AV1 Encoder and Decoder)"
+HOMEPAGE="https://github.com/AOMediaCodec/SVT-AV1"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AOMediaCodec/SVT-AV1.git"
+else
+ SRC_URI="https://github.com/AOMediaCodec/SVT-AV1/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 -x86" # -x86: https://github.com/AOMediaCodec/SVT-AV1/issues/1231
+ S="${WORKDIR}/SVT-AV1-${PV}"
+fi
+
+# Also see "Alliance for Open Media Patent License 1.0"
+LICENSE="BSD-2 Apache-2.0 BSD ISC LGPL-2.1+ MIT"
+SLOT="0"
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ local mycmakeargs=(
+ # Tests require linking against https://github.com/Cidana-Developers/aom/tree/av1-normative ?
+ # undefined reference to `ifd_inspect'
+ # https://github.com/Cidana-Developers/aom/commit/cfc5c9e95bcb48a5a41ca7908b44df34ea1313c0
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake_src_configure
+}