summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-30 17:25:04 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-30 17:38:38 -0700
commit02022f11d28ef0041133ad3877182d9cddeb2de3 (patch)
tree09a88c34d6663326dcb0f14cda0cd3fb27651cb8 /media-libs/tg_owt
parentmedia-libs/libtgvoip: bump to 20201030 snapshot (diff)
downloadgentoo-02022f11d28ef0041133ad3877182d9cddeb2de3.tar.gz
gentoo-02022f11d28ef0041133ad3877182d9cddeb2de3.tar.bz2
gentoo-02022f11d28ef0041133ad3877182d9cddeb2de3.zip
media-libs/tg_owt: new package (webrtc for telegram-desktop)
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/tg_owt')
-rw-r--r--media-libs/tg_owt/Manifest1
-rw-r--r--media-libs/tg_owt/metadata.xml8
-rw-r--r--media-libs/tg_owt/tg_owt-0_pre20201030.ebuild47
3 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/tg_owt/Manifest b/media-libs/tg_owt/Manifest
new file mode 100644
index 000000000000..6b888ca56b14
--- /dev/null
+++ b/media-libs/tg_owt/Manifest
@@ -0,0 +1 @@
+DIST tg_owt-0_pre20201030.tar.gz 18391433 BLAKE2B 518f1a0cba8615348b6757cc3d40c6f78c7ccfcb3943a39aef9ac712e1520b7d2c9b52419bb1f22966ee8210021d684df64e593403ee86a55bbf4622826a7bcb SHA512 4f8c9fdcf3f5a2086bcb00c1434ab5c0ff398de99c32166e8479dc8482cf598ed20bcd93a98c92f30e0f0d16e1cee4dbe28d4cd21feb602fc937079d487326dd
diff --git a/media-libs/tg_owt/metadata.xml b/media-libs/tg_owt/metadata.xml
new file mode 100644
index 000000000000..efcd58fe0b9b
--- /dev/null
+++ b/media-libs/tg_owt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-libs/tg_owt/tg_owt-0_pre20201030.ebuild b/media-libs/tg_owt/tg_owt-0_pre20201030.ebuild
new file mode 100644
index 000000000000..0732044bf8e1
--- /dev/null
+++ b/media-libs/tg_owt/tg_owt-0_pre20201030.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+TG_OWT_COMMIT="1d4f7d74ff1a627db6e45682efd0e3b85738e426"
+
+DESCRIPTION="WebRTC build for Telegram"
+HOMEPAGE="https://github.com/desktop-app/tg_owt"
+SRC_URI="https://github.com/desktop-app/tg_owt/archive/${TG_OWT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="pulseaudio"
+
+# some things from this list are bundled
+# work on unbundling in progress
+DEPEND="
+ dev-libs/openssl:=
+ media-libs/alsa-lib
+ media-libs/libjpeg-turbo:=
+ media-libs/libvpx:=
+ media-libs/openh264:=
+ media-libs/opus
+ media-video/ffmpeg:=
+ !pulseaudio? ( media-sound/apulse[sdk] )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ amd64? ( dev-lang/yasm )
+"
+
+S="${WORKDIR}/${PN}-${TG_OWT_COMMIT}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTG_OWT_PACKAGED_BUILD=TRUE
+ )
+ cmake_src_configure
+}