summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-23 21:36:39 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-23 21:53:02 -0800
commitb50d960b3ecec030e387df687877c78bf9519ed6 (patch)
treed5e7c3215ca8aaf2d386fe52f35b6716573a6697 /media-libs/tg_owt
parentprofiles/f/p/s/kernel-2.6.16+/p.bashrc: libuv compatibility. (diff)
downloadgentoo-b50d960b3ecec030e387df687877c78bf9519ed6.tar.gz
gentoo-b50d960b3ecec030e387df687877c78bf9519ed6.tar.bz2
gentoo-b50d960b3ecec030e387df687877c78bf9519ed6.zip
media-libs/tg_owt: bump to new snapshot
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/tg_owt')
-rw-r--r--media-libs/tg_owt/Manifest1
-rw-r--r--media-libs/tg_owt/tg_owt-0_pre20201112.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/tg_owt/Manifest b/media-libs/tg_owt/Manifest
index 4db6a7faa52a..bc40b05702a9 100644
--- a/media-libs/tg_owt/Manifest
+++ b/media-libs/tg_owt/Manifest
@@ -1 +1,2 @@
DIST tg_owt-0_pre20201105.tar.gz 18390526 BLAKE2B 115e93eb9dfd158779d2a521de9bca8cf0e0a38cff7d7a470b59d2941212a79cc7c33abf330c348ad70321486cd80d44644ceea61f9a86bbaee3ef6463a9e23d SHA512 de9d4490c3e68f17dd75e523596683395e67e91b51c5c7af61c0a51517779129cc965bc97d63b5054bdddb76d385ab33d6995d72b08316941fa2a72a93d1c3fa
+DIST tg_owt-0_pre20201112.tar.gz 18391959 BLAKE2B 85ad2880e9067daad94389708c0cb3638c090fa8281b8bf55d990dcdbf8eb898a70a930a0c0e904b0a682b9ebdb021134e18270ab760191b12cccba12dae95d5 SHA512 10f6ca1a6a82e9bd9af9e815b4d849fdace39332df61d32a9b706bffc3e8647b20f58e63a2fcc4e714e1480768ddd8f7ad21588f1e9762b3c056b205abfd5806
diff --git a/media-libs/tg_owt/tg_owt-0_pre20201112.ebuild b/media-libs/tg_owt/tg_owt-0_pre20201112.ebuild
new file mode 100644
index 000000000000..d962696ed699
--- /dev/null
+++ b/media-libs/tg_owt/tg_owt-0_pre20201112.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+TG_OWT_COMMIT="10b988aa9111fd25358443ac34d0d422b5108029"
+
+DESCRIPTION="WebRTC build for Telegram"
+HOMEPAGE="https://github.com/desktop-app/tg_owt"
+SRC_URI="https://github.com/desktop-app/tg_owt/archive/${TG_OWT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="pulseaudio"
+
+# some things from this list are bundled
+# work on unbundling in progress
+DEPEND="
+ dev-libs/openssl:=
+ dev-libs/protobuf:=
+ media-libs/alsa-lib
+ media-libs/libjpeg-turbo:=
+ media-libs/libvpx:=
+ media-libs/openh264:=
+ media-libs/opus
+ media-video/ffmpeg:=
+ !pulseaudio? ( media-sound/apulse[sdk] )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ amd64? ( dev-lang/yasm )
+"
+
+S="${WORKDIR}/${PN}-${TG_OWT_COMMIT}"
+
+src_configure() {
+ # lacks nop, can't restore toc
+ append-flags '-fPIC'
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=TRUE
+ -DTG_OWT_PACKAGED_BUILD=TRUE
+ -DTG_OWT_USE_PROTOBUF=TRUE
+ )
+ cmake_src_configure
+}