summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-19 15:01:23 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-19 15:44:35 -0500
commit73004619cc8ba46a7ee42b1496dbf0f064ccc87e (patch)
treec31f6ea4a4aeb25e73f5c83651e18b41f36763a6 /media-libs/virglrenderer/virglrenderer-0.8.2.ebuild
parentmail-filter/pypolicyd-spf: new revision with python-3.{7,8} support. (diff)
downloadgentoo-73004619cc8ba46a7ee42b1496dbf0f064ccc87e.tar.gz
gentoo-73004619cc8ba46a7ee42b1496dbf0f064ccc87e.tar.bz2
gentoo-73004619cc8ba46a7ee42b1496dbf0f064ccc87e.zip
media-libs/virglrenderer: version bump to 0.8.2
- contrary to the suggestion in https://bugs.gentoo.org/693246, do not add a USE=gbm flag. The current code cannot be compiled with mesa[gbm] and upstream restricted support for gbm allocation to minigbm in current master - port to meson build system - disable testsuite - - verified that the build system doesn't require python directly any more Closes: https://bugs.gentoo.org/693246 Closes: https://bugs.gentoo.org/716354 Closes: https://bugs.gentoo.org/631740 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'media-libs/virglrenderer/virglrenderer-0.8.2.ebuild')
-rw-r--r--media-libs/virglrenderer/virglrenderer-0.8.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/virglrenderer/virglrenderer-0.8.2.ebuild b/media-libs/virglrenderer/virglrenderer-0.8.2.ebuild
new file mode 100644
index 000000000000..d65f9a5cec75
--- /dev/null
+++ b/media-libs/virglrenderer/virglrenderer-0.8.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/virglrenderer.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/virgl/${PN}/-/archive/${P}/${PN}-${P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="library used implement a virtual 3D GPU used by qemu"
+HOMEPAGE="https://virgil3d.github.io/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND="
+ >=x11-libs/libdrm-2.4.50
+ media-libs/libepoxy"
+
+DEPEND="${RDEPEND}"
+
+# Most of the testuiste cannot run in our sandboxed environment, just don't
+# deal with it for now.
+RESTRICT="test"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ find "${ED}"/usr -name 'lib*.la' -delete
+}