summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Lombard <berillions@gmail.com>2019-03-01 16:43:41 +0100
committerNick Sarnie <sarnex@gentoo.org>2019-03-02 13:50:50 -0500
commit45221bcf69993af866073126b69fb08f2a2ea056 (patch)
treed7ca898e8a53680997397c737bf6356887622432 /media-libs/vulkan-loader
parentmedia-libs/vulkan-layers: Bump version (diff)
downloadgentoo-45221bcf69993af866073126b69fb08f2a2ea056.tar.gz
gentoo-45221bcf69993af866073126b69fb08f2a2ea056.tar.bz2
gentoo-45221bcf69993af866073126b69fb08f2a2ea056.zip
media-libs/vulkan-loader: Bump version
Version bump to 1.1.101. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Maxime Lombard <berillions@gmail.com> Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-libs/vulkan-loader')
-rw-r--r--media-libs/vulkan-loader/Manifest1
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.1.101.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/vulkan-loader/Manifest b/media-libs/vulkan-loader/Manifest
index 3c3352fae7eb..41c05f4b83bf 100644
--- a/media-libs/vulkan-loader/Manifest
+++ b/media-libs/vulkan-loader/Manifest
@@ -1,2 +1,3 @@
+DIST vulkan-loader-1.1.101.tar.gz 1346567 BLAKE2B a116df430606e4d94a94c5b307319e4f0d366353f1949c27f5dc3bcbd9997bb97e7d7dc13f141c0423ab162706399a45693da5dc5ed7e6802cc65ec55c711724 SHA512 b26a9389a90cd833c7b18a50766ee0d54ad52aa252d33eb1760ebef38305559664974198a84b0ddbe92950fffc8d2a136c23acff40f73d3cbbd183bc75489a10
DIST vulkan-loader-1.1.82.0.tar.gz 1342427 BLAKE2B 4b2c589e2c1edaa29e13e892cc839f2d7af5bbadf7dda3f50eca2543c1877af175e9640545b886ffe3e8b1c51373502ee272829ddb15c07629ea08ece697e5b9 SHA512 624e493454e622e29bc0de5fdf1c425691b3c98f317660847e95aee6bc42dafa0b4d8caa9de52e8f3229b7e743afa475485cd3affbdb295e16ba49d30d1eb19e
DIST vulkan-loader-1.1.92.1.tar.gz 1346712 BLAKE2B 60d29c38e72ff234261a3e75934d44de08c334c475e715066c210844ea672f0e2db3ebc8826df7d72392e3c2a0bbd0604b8770c0b35ddd8f72ed875234bae15d SHA512 c29d1fb43a2bdd0f291860dee0ffe7ec23a34c9431aeb76a46f8df0ec2f70601ccd3e96280f94d881f5550e3c9f07fe478f94eebcfd2aaf123045c7281313aac
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.1.101.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.1.101.ebuild
new file mode 100644
index 000000000000..28212063359d
--- /dev/null
+++ b/media-libs/vulkan-loader/vulkan-loader-1.1.101.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Loader.git"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="15fa85d92454f7823febeb68b56038d427e2a7a4"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-Loader-${EGIT_COMMIT}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="layers wayland X"
+
+PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
+DEPEND="${PYTHON_DEPS}
+ >=dev-util/vulkan-headers-1.1.101
+ wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11:=[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=True
+ -DBUILD_TESTS=False
+ -DBUILD_LOADER=True
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ -DVULKAN_HEADERS_INSTALL_DIR="/usr"
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ keepdir /etc/vulkan/icd.d
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ einfo "USE=demos has been dropped as per upstream packaging"
+ einfo "vulkaninfo is now available in the dev-util/vulkan-tools package"
+}