summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-08-01 14:35:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-08-02 09:39:15 +0200
commit0b50758465d254406ad2434b39f402bf52f4fd74 (patch)
tree8621942689421262e924e99e977d19d7132508f1 /media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1.ebuild
parentdev-libs/libinput: Removed old. (diff)
downloadgentoo-0b50758465d254406ad2434b39f402bf52f4fd74.tar.gz
gentoo-0b50758465d254406ad2434b39f402bf52f4fd74.tar.bz2
gentoo-0b50758465d254406ad2434b39f402bf52f4fd74.zip
media-libs/webrtc-audio-processing: Bump to version 0.3.1
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1.ebuild')
-rw-r--r--media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1.ebuild b/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1.ebuild
new file mode 100644
index 000000000000..aa748cab6267
--- /dev/null
+++ b/media-libs/webrtc-audio-processing/webrtc-audio-processing-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="AudioProcessing library from the webrtc.org code base"
+HOMEPAGE="https://www.freedesktop.org/software/pulseaudio/webrtc-audio-processing/"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+DOCS=( AUTHORS NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3-proper_detection_cxxabi_execinfo.patch
+)
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}