summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-24 13:21:52 +0200
committerPacho Ramos <pacho@gentoo.org>2015-10-24 13:22:04 +0200
commit91f7caa31a3e0ff4cdbafbdeb7e4e0fe6d605496 (patch)
treec46344cb98be61bf25fa3185a93c0f32b1d464a1 /media-libs/wxsvg/wxsvg-1.5.4-r1.ebuild
parentnet-misc/electrum: bump to 2.5.1, bug #563866. (diff)
downloadgentoo-91f7caa31a3e0ff4cdbafbdeb7e4e0fe6d605496.tar.gz
gentoo-91f7caa31a3e0ff4cdbafbdeb7e4e0fe6d605496.tar.bz2
gentoo-91f7caa31a3e0ff4cdbafbdeb7e4e0fe6d605496.zip
media-libs/wxsvg: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/wxsvg/wxsvg-1.5.4-r1.ebuild')
-rw-r--r--media-libs/wxsvg/wxsvg-1.5.4-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/wxsvg/wxsvg-1.5.4-r1.ebuild b/media-libs/wxsvg/wxsvg-1.5.4-r1.ebuild
new file mode 100644
index 000000000000..2e90d36c6385
--- /dev/null
+++ b/media-libs/wxsvg/wxsvg-1.5.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER=3.0
+inherit eutils wxwidgets
+
+DESCRIPTION="C++ library to create, manipulate and render SVG files"
+HOMEPAGE="http://wxsvg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="wxWinLL-3"
+SLOT="0/3" # based on SONAME of libwxsvg.so
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/expat-2:=
+ >=dev-libs/glib-2.28:2=
+ dev-libs/libxml2:=
+ media-libs/fontconfig:=
+ media-libs/freetype:2=
+ x11-libs/cairo:=
+ x11-libs/pango:=
+ x11-libs/wxGTK:${WX_GTK_VER}=[X]
+ virtual/ffmpeg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog TODO )
+
+src_configure() {
+ need-wxwidgets base-unicode
+ econf \
+ $(use_enable static-libs static) \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}