summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-02-15 12:45:41 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-02-15 13:35:53 +0100
commit31758d0f0f39e32330321eb346e6c792b8903ea3 (patch)
tree7ea128ab79a61beee28062eb45f5aea8f820ec97 /media-libs/x264/x264-0.0.20190214.ebuild
parentsci-electronics/gazebo: bump to 10.0.0 (diff)
downloadgentoo-31758d0f0f39e32330321eb346e6c792b8903ea3.tar.gz
gentoo-31758d0f0f39e32330321eb346e6c792b8903ea3.tar.bz2
gentoo-31758d0f0f39e32330321eb346e6c792b8903ea3.zip
media-libs/x264: bump a new snapshot, api 157
Closes: https://bugs.gentoo.org/676596 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/x264/x264-0.0.20190214.ebuild')
-rw-r--r--media-libs/x264/x264-0.0.20190214.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/x264/x264-0.0.20190214.ebuild b/media-libs/x264/x264-0.0.20190214.ebuild
new file mode 100644
index 000000000000..0128bcd158b6
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20190214.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="https://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.videolan.org/git/x264.git"
+else
+ MY_P="x264-snapshot-$(ver_cut 3)-2245"
+ SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+SLOT="0/157" # SONAME
+
+LICENSE="GPL-2"
+IUSE="altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+
+ASM_DEP=">=dev-lang/nasm-2.13"
+DEPEND="abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )
+ opencl? ( dev-lang/perl )"
+RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
+
+multilib_src_configure() {
+ tc-export CC
+ local asm_conf=""
+
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
+ asm_conf=" --disable-asm"
+ fi
+
+ "${S}/configure" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ $(usex interlaced "" "--disable-interlaced") \
+ $(usex opencl "" "--disable-opencl") \
+ $(usex static-libs "--enable-static" "") \
+ $(usex threads "" "--disable-thread") \
+ ${asm_conf} || die
+}