summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 16:40:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 16:40:34 +0200
commit3907b55b37a0fc3f64b75c016da488313ac4dfb7 (patch)
tree86e0e4b1995684b31d295d6920d00e9c26af2838 /media-libs/x265/x265-9999.ebuild
parentmedia-libs/x265: Make src_test more robust. (diff)
downloadgentoo-3907b55b37a0fc3f64b75c016da488313ac4dfb7.tar.gz
gentoo-3907b55b37a0fc3f64b75c016da488313ac4dfb7.tar.bz2
gentoo-3907b55b37a0fc3f64b75c016da488313ac4dfb7.zip
media-libs/x265: Fix automagic on numactl. Bug #555012.
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/x265/x265-9999.ebuild')
-rw-r--r--media-libs/x265/x265-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 0d77b7137956..fbb609d1c389 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -22,10 +22,10 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/75"
-IUSE="+10bit pic test"
+IUSE="+10bit numa pic test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
-RDEPEND=""
+RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )"
@@ -47,6 +47,7 @@ multilib_src_configure() {
local mycmakeargs=(
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
+ -DCMAKE_DISABLE_FIND_PACKAGE_Numa=$(usex numa OFF ON)
-DHIGH_BIT_DEPTH=$(usex 10bit "ON" "OFF")
-DLIB_INSTALL_DIR="$(get_libdir)"
)