summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2014-07-28 20:12:43 +0200
committerBertrand Jacquin <bertrand@jacquin.bzh>2015-10-14 00:26:19 +0100
commit5658f1dc7a9c128630e2c4b0b843ecfd14cbf592 (patch)
tree123839cd3847179ca09c717b0a887d04331df268 /media-libs/x265/x265-9999.ebuild
parentprofiles/package.mask: remove old openrc-0.18.1 mask (diff)
downloadgentoo-5658f1dc7a9c128630e2c4b0b843ecfd14cbf592.tar.gz
gentoo-5658f1dc7a9c128630e2c4b0b843ecfd14cbf592.tar.bz2
gentoo-5658f1dc7a9c128630e2c4b0b843ecfd14cbf592.zip
media-libs/x265: Fix x32 build, bug #510890
x32 arch as defined on https://sites.google.com/site/x32abi is neither X86 nor X64, then forcing -march=i686 leads to build failure as wrong -march is used. Forcing -march, -mfloat-abi and -mfpu for ARM is also wrong As a global sanity sake, disable all forced -march in CMakeLists Upstream report: https://bitbucket.org/multicoreware/x265/pull-requests/21/build-disable-march-selection-from/diff Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs/x265/x265-9999.ebuild')
-rw-r--r--media-libs/x265/x265-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 8a3e36f86b72..5b0348cfe2a3 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -51,9 +51,12 @@ multilib_src_configure() {
-DLIB_INSTALL_DIR="$(get_libdir)"
)
- if [ "${ABI}" = x86 ] ; then
+ if [[ ${ABI} = x86 ]] ; then
use 10bit && ewarn "Disabling 10bit support on x86 as it does not build (or requires to disable assembly optimizations)"
mycmakeargs+=( -DHIGH_BIT_DEPTH=OFF )
+ elif [[ ${ABI} = x32 ]] ; then
+ # bug #510890
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
cmake-utils_src_configure