summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/x265
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/Manifest2
-rw-r--r--media-libs/x265/metadata.xml11
-rw-r--r--media-libs/x265/x265-1.5.ebuild74
-rw-r--r--media-libs/x265/x265-1.7.ebuild82
-rw-r--r--media-libs/x265/x265-9999.ebuild82
5 files changed, 251 insertions, 0 deletions
diff --git a/media-libs/x265/Manifest b/media-libs/x265/Manifest
new file mode 100644
index 000000000000..ff456413d5c6
--- /dev/null
+++ b/media-libs/x265/Manifest
@@ -0,0 +1,2 @@
+DIST x265-1.5.tar.bz2 588263 SHA256 da226cbe56938f85d5a3d123d1f5ca895795f2eac794e45af4b70047e03d8648 SHA512 e5db8c3428b7b393c5c3049041de152b43821a083bc1988903ade8d6ce5fdc71a2fe0ad9efa0564aa3c2c6f1ec31659fcd2b338f6b53d22a202811be7071f077 WHIRLPOOL 9e1256832a3ece06d68a872b44337285afbbeebbd149ac71fda25524d60310f595adedce1b28f0ed5a59feadef39848d797bd58f4b0d7c7d707bcddca7520f6d
+DIST x265_1.7.tar.gz 844212 SHA256 a52ca95e8e64219c1e8e73a9abf0bb7151ced2c93756a623cf2b7e5cf8226585 SHA512 cf6fce24b008d36bbc79e2488ab5fb3010aa588113645597ffc66959088a73b3ba72f6bb81bd16e36847a73b50b8f264cff0899162552418ae499170c286eb89 WHIRLPOOL 9c932fd85fbc06a63802f8aabdbb5f44fe4bee6bc2d0996df8788acad30be965bde7b56f562e4ca8ae87856fbcf728b6938a701afb397ef2195437b73a60c744
diff --git a/media-libs/x265/metadata.xml b/media-libs/x265/metadata.xml
new file mode 100644
index 000000000000..e4623460933e
--- /dev/null
+++ b/media-libs/x265/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="10bit">Set output bit depth to 10</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-libs/x265/x265-1.5.ebuild b/media-libs/x265/x265-1.5.ebuild
new file mode 100644
index 000000000000..2ca373a3f259
--- /dev/null
+++ b/media-libs/x265/x265-1.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib multilib flag-o-matic
+
+if [[ ${PV} = 9999* ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://bitbucket.org/multicoreware/x265"
+else
+ SRC_URI="https://bitbucket.org/multicoreware/x265/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="amd64 arm hppa ~ppc ~ppc64 x86"
+fi
+
+DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
+HOMEPAGE="http://x265.org/"
+
+LICENSE="GPL-2"
+# subslot = libx265 soname
+SLOT="0/43"
+IUSE="+10bit test"
+
+ASM_DEPEND=">=dev-lang/yasm-1.2.0"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )"
+
+src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ mercurial_src_unpack
+ # Can't set it at global scope due to mercurial.eclass limitations...
+ export S=${WORKDIR}/${P}/source
+ else
+ unpack ${A}
+ export S=$(echo "${WORKDIR}"/*${PN}*/source)
+ fi
+}
+
+multilib_src_configure() {
+ append-cflags -fPIC
+ append-cxxflags -fPIC
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test TESTS)
+ $(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
+ -DHIGH_BIT_DEPTH=$(usex 10bit "ON" "OFF")
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+ cmake-utils_src_configure
+}
+
+src_configure() {
+ multilib_parallel_foreach_abi multilib_src_configure
+}
+
+multilib_src_test() {
+ if has ${MULTILIB_ABI_FLAG} abi_x86_32 abi_x86_64 ; then
+ cd "${BUILD_DIR}/test" || die
+ for i in TestBench ; do
+ ./${i} || die
+ done
+ fi
+}
+
+src_test() {
+ multilib_foreach_abi multilib_src_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+ dodoc -r "${S}/../doc/"*
+}
diff --git a/media-libs/x265/x265-1.7.ebuild b/media-libs/x265/x265-1.7.ebuild
new file mode 100644
index 000000000000..547690a50b9a
--- /dev/null
+++ b/media-libs/x265/x265-1.7.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib multilib flag-o-matic
+
+if [[ ${PV} = 9999* ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://bitbucket.org/multicoreware/x265"
+else
+ SRC_URI="
+ https://bitbucket.org/multicoreware/x265/downloads/${PN}_${PV}.tar.gz
+ http://ftp.videolan.org/pub/videolan/x265/${PN}_${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
+HOMEPAGE="http://x265.org/"
+
+LICENSE="GPL-2"
+# subslot = libx265 soname
+SLOT="0/59"
+IUSE="+10bit test"
+
+ASM_DEPEND=">=dev-lang/yasm-1.2.0"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )"
+
+src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ mercurial_src_unpack
+ # Can't set it at global scope due to mercurial.eclass limitations...
+ export S=${WORKDIR}/${P}/source
+ else
+ unpack ${A}
+ export S="${WORKDIR}/${PN}_${PV}/source"
+ fi
+}
+
+multilib_src_configure() {
+ append-cflags -fPIC
+ append-cxxflags -fPIC
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test TESTS)
+ $(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
+ -DHIGH_BIT_DEPTH=$(usex 10bit "ON" "OFF")
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ if [ "${ABI}" = x86 ] ; then
+ use 10bit && ewarn "Disabling 10bit support on x86 as it does not build (or requires to disable assembly optimizations)"
+ mycmakeargs+=( -DHIGH_BIT_DEPTH=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_configure() {
+ multilib_parallel_foreach_abi multilib_src_configure
+}
+
+multilib_src_test() {
+ if has ${MULTILIB_ABI_FLAG} abi_x86_32 abi_x86_64 ; then
+ cd "${BUILD_DIR}/test" || die
+ for i in TestBench ; do
+ ./${i} || die
+ done
+ fi
+}
+
+src_test() {
+ multilib_foreach_abi multilib_src_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+ dodoc -r "${S}/../doc/"*
+}
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
new file mode 100644
index 000000000000..547690a50b9a
--- /dev/null
+++ b/media-libs/x265/x265-9999.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib multilib flag-o-matic
+
+if [[ ${PV} = 9999* ]]; then
+ inherit mercurial
+ EHG_REPO_URI="http://bitbucket.org/multicoreware/x265"
+else
+ SRC_URI="
+ https://bitbucket.org/multicoreware/x265/downloads/${PN}_${PV}.tar.gz
+ http://ftp.videolan.org/pub/videolan/x265/${PN}_${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
+HOMEPAGE="http://x265.org/"
+
+LICENSE="GPL-2"
+# subslot = libx265 soname
+SLOT="0/59"
+IUSE="+10bit test"
+
+ASM_DEPEND=">=dev-lang/yasm-1.2.0"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )"
+
+src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ mercurial_src_unpack
+ # Can't set it at global scope due to mercurial.eclass limitations...
+ export S=${WORKDIR}/${P}/source
+ else
+ unpack ${A}
+ export S="${WORKDIR}/${PN}_${PV}/source"
+ fi
+}
+
+multilib_src_configure() {
+ append-cflags -fPIC
+ append-cxxflags -fPIC
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test TESTS)
+ $(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
+ -DHIGH_BIT_DEPTH=$(usex 10bit "ON" "OFF")
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ if [ "${ABI}" = x86 ] ; then
+ use 10bit && ewarn "Disabling 10bit support on x86 as it does not build (or requires to disable assembly optimizations)"
+ mycmakeargs+=( -DHIGH_BIT_DEPTH=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_configure() {
+ multilib_parallel_foreach_abi multilib_src_configure
+}
+
+multilib_src_test() {
+ if has ${MULTILIB_ABI_FLAG} abi_x86_32 abi_x86_64 ; then
+ cd "${BUILD_DIR}/test" || die
+ for i in TestBench ; do
+ ./${i} || die
+ done
+ fi
+}
+
+src_test() {
+ multilib_foreach_abi multilib_src_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+ dodoc -r "${S}/../doc/"*
+}