summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-08 11:13:43 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-08 11:23:18 -0700
commit6a40ed6d96df469070d907833f67663ce88cec6b (patch)
tree0e9a44efd6ce5c2b146a26a94e9db1e83ed3af81 /media-libs/x265
parentdev-libs/rocclr: Radeon Open Compute Common Language Runtime (diff)
downloadgentoo-6a40ed6d96df469070d907833f67663ce88cec6b.tar.gz
gentoo-6a40ed6d96df469070d907833f67663ce88cec6b.tar.bz2
gentoo-6a40ed6d96df469070d907833f67663ce88cec6b.zip
media-libs/x265: add cpu_flags_ppc_vsx2 to 3.4
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/x265-3.4.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/media-libs/x265/x265-3.4.ebuild b/media-libs/x265/x265-3.4.ebuild
index 8d6664cdef27..65ee36367eef 100644
--- a/media-libs/x265/x265-3.4.ebuild
+++ b/media-libs/x265/x265-3.4.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/ https://bitbucket.org/multicoreware/x265/wiki/Home"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/192"
-IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_altivec numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -96,7 +96,7 @@ x265_variant_src_configure() {
if [[ ${ABI} = ppc* ]] ; then
mycmakeargs+=(
-DENABLE_ALTIVEC=OFF
- -DCPU_POWER8=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
)
fi
;;
@@ -118,7 +118,7 @@ x265_variant_src_configure() {
if [[ ${ABI} = ppc* ]] ; then
mycmakeargs+=(
-DENABLE_ALTIVEC=OFF
- -DCPU_POWER8=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
)
fi
;;
@@ -138,9 +138,13 @@ x265_variant_src_configure() {
-DLINKED_12BIT=$(usex 12bit)
)
if [[ ${ABI} = ppc* ]] ; then
+ # upstream uses mix of altivec + power8 vectors
+ # it's impossible to enable altivec without CPU_POWER8
+ # and it does not work on ppc32
+ # so we toggle both variables together
mycmakeargs+=(
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_altivec ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
)
fi
fi