summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-08 11:39:32 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-08 12:33:09 -0700
commit7a9177eb6ef769dc342948c632b721426595ab41 (patch)
tree6076087b71868c9d4afbab63965d5302451d9b25 /media-libs/x265
parentsci-libs/volk: add comment for build_type (diff)
downloadgentoo-7a9177eb6ef769dc342948c632b721426595ab41.tar.gz
gentoo-7a9177eb6ef769dc342948c632b721426595ab41.tar.bz2
gentoo-7a9177eb6ef769dc342948c632b721426595ab41.zip
media-libs/x265: migrate to cpu_flags_ppc_vsx2 instead of power8
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/metadata.xml1
-rw-r--r--media-libs/x265/x265-2.8.ebuild8
-rw-r--r--media-libs/x265/x265-2.9.ebuild8
-rw-r--r--media-libs/x265/x265-3.0.ebuild8
-rw-r--r--media-libs/x265/x265-3.1.2.ebuild8
-rw-r--r--media-libs/x265/x265-3.1.ebuild8
-rw-r--r--media-libs/x265/x265-3.2.1.ebuild6
-rw-r--r--media-libs/x265/x265-3.2.ebuild8
-rw-r--r--media-libs/x265/x265-3.3.ebuild6
9 files changed, 30 insertions, 31 deletions
diff --git a/media-libs/x265/metadata.xml b/media-libs/x265/metadata.xml
index c585d5536314..2049b41f26e7 100644
--- a/media-libs/x265/metadata.xml
+++ b/media-libs/x265/metadata.xml
@@ -10,7 +10,6 @@
<flag name="12bit">Add support for producing 12bits HEVC.</flag>
<flag name="numa">Build with support for NUMA nodes.</flag>
<flag name="pic">Disable optimized assembly code that is not PIC friendly</flag>
- <flag name="power8">Enable support for Power 8 assembly optimizations.</flag>
</use>
<upstream>
<remote-id type="bitbucket">multicoreware/x265</remote-id>
diff --git a/media-libs/x265/x265-2.8.ebuild b/media-libs/x265/x265-2.8.ebuild
index f4bb545314bb..3041c243b775 100644
--- a/media-libs/x265/x265-2.8.ebuild
+++ b/media-libs/x265/x265-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/160"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -143,8 +143,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-2.9.ebuild b/media-libs/x265/x265-2.9.ebuild
index 5f28b491babf..ead3e157954e 100644
--- a/media-libs/x265/x265-2.9.ebuild
+++ b/media-libs/x265/x265-2.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/165"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -143,8 +143,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-3.0.ebuild b/media-libs/x265/x265-3.0.ebuild
index 2d1942d399d2..df633a2e1d7f 100644
--- a/media-libs/x265/x265-3.0.ebuild
+++ b/media-libs/x265/x265-3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/169"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -142,8 +142,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-3.1.2.ebuild b/media-libs/x265/x265-3.1.2.ebuild
index 71303686d68a..b69d74af9802 100644
--- a/media-libs/x265/x265-3.1.2.ebuild
+++ b/media-libs/x265/x265-3.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/176"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -142,8 +142,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-3.1.ebuild b/media-libs/x265/x265-3.1.ebuild
index 71303686d68a..b69d74af9802 100644
--- a/media-libs/x265/x265-3.1.ebuild
+++ b/media-libs/x265/x265-3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/176"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -142,8 +142,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-3.2.1.ebuild b/media-libs/x265/x265-3.2.1.ebuild
index a7c7ebc8e962..6ce84bf0fa10 100644
--- a/media-libs/x265/x265-3.2.1.ebuild
+++ b/media-libs/x265/x265-3.2.1.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/179"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -142,8 +142,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-3.2.ebuild b/media-libs/x265/x265-3.2.ebuild
index b1d719a14b6c..6ce84bf0fa10 100644
--- a/media-libs/x265/x265-3.2.ebuild
+++ b/media-libs/x265/x265-3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/179"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -142,8 +142,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)
diff --git a/media-libs/x265/x265-3.3.ebuild b/media-libs/x265/x265-3.3.ebuild
index 736bea15bb84..1bcd7b28a790 100644
--- a/media-libs/x265/x265-3.3.ebuild
+++ b/media-libs/x265/x265-3.3.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="http://x265.org/ https://bitbucket.org/multicoreware/x265/wiki/Home"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/188"
-IUSE="+asm +10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_altivec numa power8 test"
+IUSE="+asm +10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa test"
# Test suite requires assembly support and is known to be broken
RESTRICT="test"
@@ -120,8 +120,8 @@ x265_variant_src_configure() {
# because we want those flags apply ONLY to "main" variant
if [[ ${ABI} = ppc* ]] ; then
myabicmakeargs+=(
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_altivec ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
)
fi
fi