summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-30 14:39:18 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-30 14:57:00 +0100
commit6067d19b4660a0e43c37280dcbf01b20d0d8a33a (patch)
treeb6a0953370eadf8e9fe9196a284990c7341e01fd /media-libs/zimg/zimg-2.6.3.ebuild
parentmedia-video/ffmpeg: update zimg dep in live ebuild (diff)
downloadgentoo-6067d19b4660a0e43c37280dcbf01b20d0d8a33a.tar.gz
gentoo-6067d19b4660a0e43c37280dcbf01b20d0d8a33a.tar.bz2
gentoo-6067d19b4660a0e43c37280dcbf01b20d0d8a33a.zip
media-libs/zimg: bump to 2.6.3
Closes: https://bugs.gentoo.org/633748 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-libs/zimg/zimg-2.6.3.ebuild')
-rw-r--r--media-libs/zimg/zimg-2.6.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-2.6.3.ebuild b/media-libs/zimg/zimg-2.6.3.ebuild
new file mode 100644
index 000000000000..efc3a2b24237
--- /dev/null
+++ b/media-libs/zimg/zimg-2.6.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}