summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/zvbi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/zvbi')
-rw-r--r--media-libs/zvbi/Manifest1
-rw-r--r--media-libs/zvbi/metadata.xml12
-rw-r--r--media-libs/zvbi/zvbi-0.2.35-r1.ebuild51
-rw-r--r--media-libs/zvbi/zvbi-0.2.35.ebuild48
4 files changed, 112 insertions, 0 deletions
diff --git a/media-libs/zvbi/Manifest b/media-libs/zvbi/Manifest
new file mode 100644
index 000000000000..8b65f92ccb78
--- /dev/null
+++ b/media-libs/zvbi/Manifest
@@ -0,0 +1 @@
+DIST zvbi-0.2.35.tar.bz2 1047761 SHA256 fc883c34111a487c4a783f91b1b2bb5610d8d8e58dcba80c7ab31e67e4765318 SHA512 3d73eb0a7d05fdf1e3f8a74cc9d4fcb2a0287285904d59230c832f42b91afb072e96bda7e396ef07f268348061a51242925746db124bbb713cf56bdfabdada5d WHIRLPOOL e365d28db9834a5e9f8780d45f9fcb04c7b98e5a3122fe81336a42bb2de54505583a535908cabc0851b6753f589b758bf1d6e2831c88cfbeba9fe8d0633a42f0
diff --git a/media-libs/zvbi/metadata.xml b/media-libs/zvbi/metadata.xml
new file mode 100644
index 000000000000..d4fa9a81e2b5
--- /dev/null
+++ b/media-libs/zvbi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>media-tv@gentoo.org</email>
+ <name>Television related Applications in Gentoo's Portage</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">zapping</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/zvbi/zvbi-0.2.35-r1.ebuild b/media-libs/zvbi/zvbi-0.2.35-r1.ebuild
new file mode 100644
index 000000000000..0a275cc00199
--- /dev/null
+++ b/media-libs/zvbi/zvbi-0.2.35-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool multilib-minimal
+
+DESCRIPTION="VBI Decoding Library for Zapping"
+SRC_URI="mirror://sourceforge/zapping/${P}.tar.bz2"
+HOMEPAGE="http://zapping.sourceforge.net"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dvb nls static-libs v4l X"
+
+RDEPEND=">=media-libs/libpng-1.5.18[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ X? ( x11-libs/libXt )"
+
+src_prepare() {
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable v4l) \
+ $(use_enable dvb) \
+ $(use_enable nls) \
+ $(use_with X x) \
+ $(multilib_native_use_with doc doxygen)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ multilib_is_native_abi && use doc && dohtml -a png,gif,html,css doc/html/*
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+
+ find "${D}" -name '*.la' -delete
+}
diff --git a/media-libs/zvbi/zvbi-0.2.35.ebuild b/media-libs/zvbi/zvbi-0.2.35.ebuild
new file mode 100644
index 000000000000..679692dae8ee
--- /dev/null
+++ b/media-libs/zvbi/zvbi-0.2.35.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool
+
+DESCRIPTION="VBI Decoding Library for Zapping"
+SRC_URI="mirror://sourceforge/zapping/${P}.tar.bz2"
+HOMEPAGE="http://zapping.sourceforge.net"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dvb nls static-libs v4l X"
+
+RDEPEND=">=media-libs/libpng-1.4
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ X? ( x11-libs/libXt )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable v4l) \
+ $(use_enable dvb) \
+ $(use_enable nls) \
+ $(use_with X x) \
+ $(use_with doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ use doc && dohtml -a png,gif,html,css doc/html/*
+
+ find "${D}" -name '*.la' -delete
+}