summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-16 13:45:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-16 13:46:07 +0200
commit16bd0a64848882b130353c7163410f4356896777 (patch)
tree362e25de23caf4a0386669337b6a341326e9da61 /media-libs
parentx11-terms/rxvt-unicode: Old (diff)
downloadgentoo-16bd0a64848882b130353c7163410f4356896777.tar.gz
gentoo-16bd0a64848882b130353c7163410f4356896777.tar.bz2
gentoo-16bd0a64848882b130353c7163410f4356896777.zip
media-libs/libraw: Bump to version 0.20.2
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libraw/Manifest1
-rw-r--r--media-libs/libraw/libraw-0.20.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libraw/Manifest b/media-libs/libraw/Manifest
index e1e4e9d367d5..015674740683 100644
--- a/media-libs/libraw/Manifest
+++ b/media-libs/libraw/Manifest
@@ -1 +1,2 @@
DIST LibRaw-0.20.0.tar.gz 1431412 BLAKE2B 455649b600926a6a53924e4cfea33143fdd8658804cc5c19f0bb6ff5bc4a0f73ce6e45385a0edd5c78e290c8a1e32a6e3cb5a2a4c53318c046b6c4c5e6476acf SHA512 98c1d61b01fd8d408297960f63ba56d23f170ca820db7cb2c2ad5f0c9494ce79d4d615d76a6835e046589e76031a553d6e1c692e7e3e66655bc96f4d4847d7ac
+DIST LibRaw-0.20.2.tar.gz 1432141 BLAKE2B 6e41d91b560951ad4595c41a1d089505ca91337f4fc6b98bafe44211971bee143709482a070bacb7daebbd643bbbf17730f544d791c0237bf1689a7a59133079 SHA512 96b1aaf09e2d46448d1b3619270c1f1c32e9bcbd866567cec67d5b1f889362f0fae3f3533ea9bf6a11a917be3b61ee6c9938bad09209d93453039ed04eaeae4a
diff --git a/media-libs/libraw/libraw-0.20.2.ebuild b/media-libs/libraw/libraw-0.20.2.ebuild
new file mode 100644
index 000000000000..16d3dcca644d
--- /dev/null
+++ b/media-libs/libraw/libraw-0.20.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal toolchain-funcs
+
+MY_PN=LibRaw
+MY_PV="${PV/_b/-B}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
+HOMEPAGE="https://www.libraw.org/ https://github.com/LibRaw/LibRaw"
+SRC_URI="https://www.libraw.org/data/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 CDDL"
+SLOT="0/20"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples jpeg +lcms openmp"
+
+RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ lcms? ( >=media-libs/lcms-2.5:2[${MULTILIB_USEDEP}] )"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( Changelog.txt README.md )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --disable-jasper
+ $(use_enable examples)
+ $(use_enable jpeg)
+ $(use_enable lcms)
+ $(use_enable openmp)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package installs .pc files
+ find "${D}" -name '*.la' -delete || die
+}