summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-10-03 21:47:19 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-10-03 21:48:00 +0100
commit361616ee4d919fd2c898f673cb50ea0ee2d8ba7c (patch)
tree8fef66c3e3416d97239418a0a29c038a8e40a9a2 /media-libs
parentgames-fps/unreal: Fix SRC_URI to deal with unfetchable files (diff)
downloadgentoo-361616ee4d919fd2c898f673cb50ea0ee2d8ba7c.tar.gz
gentoo-361616ee4d919fd2c898f673cb50ea0ee2d8ba7c.tar.bz2
gentoo-361616ee4d919fd2c898f673cb50ea0ee2d8ba7c.zip
media-libs/allegro: Patch against undefined ref to get_value in 4.4.2
Closes: https://bugs.gentoo.org/696034 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/allegro/allegro-4.4.2-r2.ebuild1
-rw-r--r--media-libs/allegro/files/allegro-4.4.2-static-func.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/media-libs/allegro/allegro-4.4.2-r2.ebuild b/media-libs/allegro/allegro-4.4.2-r2.ebuild
index e808173e2f33..08dd7f1068c6 100644
--- a/media-libs/allegro/allegro-4.4.2-r2.ebuild
+++ b/media-libs/allegro/allegro-4.4.2-r2.ebuild
@@ -47,6 +47,7 @@ PATCHES=(
"${FILESDIR}"/${P}-Werror-format-security.patch # bug 540470
"${FILESDIR}"/${P}-glibc228.patch # bug 670781
"${FILESDIR}"/${P}-GLX_RGBA_FLOAT_BIT.patch # bug 672858
+ "${FILESDIR}"/${P}-static-func.patch # bug 696034
)
src_prepare() {
diff --git a/media-libs/allegro/files/allegro-4.4.2-static-func.patch b/media-libs/allegro/files/allegro-4.4.2-static-func.patch
new file mode 100644
index 000000000000..ac107d387d56
--- /dev/null
+++ b/media-libs/allegro/files/allegro-4.4.2-static-func.patch
@@ -0,0 +1,13 @@
+https://sourceforge.net/p/alleg/bugs/398/
+
+--- a/addons/jpgalleg/src/decode.c 2008-02-13 14:04:57.000000000 +0100
++++ b/addons/jpgalleg/src/decode.c 2015-09-03 14:57:57.888485546 +0200
+@@ -477,7 +477,7 @@
+ * Reads a string of bits from the input stream and returns a properly signed
+ * number given the category.
+ */
+-INLINE int
++static INLINE int
+ get_value(int category)
+ {
+ int result = get_bits(category);