summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-04-16 19:00:45 +0200
committerJohannes Huber <johu@gentoo.org>2018-04-16 19:01:07 +0200
commit371d17a7b85af02fa78ed05ccef0a8f1c12aa77b (patch)
treef0f00cb8ec5a0c37808c9171591e89636d681ee3 /media-libs
parentmedia-libs/libsbsms: Remove 2.0.1 (diff)
downloadgentoo-371d17a7b85af02fa78ed05ccef0a8f1c12aa77b.tar.gz
gentoo-371d17a7b85af02fa78ed05ccef0a8f1c12aa77b.tar.bz2
gentoo-371d17a7b85af02fa78ed05ccef0a8f1c12aa77b.zip
media-libs/libsbsms: Revision bump 2.0.2-r1
EAPI 6 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libsbsms/libsbsms-2.0.2-r1.ebuild b/media-libs/libsbsms/libsbsms-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..4e77d0d1ecce
--- /dev/null
+++ b/media-libs/libsbsms/libsbsms-2.0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+AUTOTOOLS_AUTORECONF=true
+inherit eutils autotools
+
+DESCRIPTION="A library for high quality time and pitch scale modification"
+HOMEPAGE="http://sbsms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="cpu_flags_x86_sse static-libs"
+
+PATCHES=( "${FILESDIR}/${P}-cflags.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ --disable-multithreaded
+ # threaded version causes segfaults
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}