summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-24 22:04:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-24 22:04:52 +0200
commit6591ec4e2f87271dd3823f910b00138f245ec489 (patch)
treee31edc4b503f41c653db32a1df46c486abeabd19 /media-libs
parentdev-libs/libical: Set -DICAL_GLIB_VAPI=OFF (diff)
downloadgentoo-6591ec4e2f87271dd3823f910b00138f245ec489.tar.gz
gentoo-6591ec4e2f87271dd3823f910b00138f245ec489.tar.bz2
gentoo-6591ec4e2f87271dd3823f910b00138f245ec489.zip
media-libs/codec2: Drop unused deps from cmake
Closes: https://bugs.gentoo.org/653926 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/codec2/codec2-0.8.1.ebuild7
-rw-r--r--media-libs/codec2/files/codec2-0.8.1-unused-deps.patch79
2 files changed, 82 insertions, 4 deletions
diff --git a/media-libs/codec2/codec2-0.8.1.ebuild b/media-libs/codec2/codec2-0.8.1.ebuild
index f220838eef34..78da953304a8 100644
--- a/media-libs/codec2/codec2-0.8.1.ebuild
+++ b/media-libs/codec2/codec2-0.8.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-multilib
@@ -14,8 +14,7 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
IUSE="examples"
-DEPEND=""
-RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-unused-deps.patch" )
multilib_src_configure() {
local mycmakeargs=( -DUNITTEST=OFF )
diff --git a/media-libs/codec2/files/codec2-0.8.1-unused-deps.patch b/media-libs/codec2/files/codec2-0.8.1-unused-deps.patch
new file mode 100644
index 000000000000..174e5173aa66
--- /dev/null
+++ b/media-libs/codec2/files/codec2-0.8.1-unused-deps.patch
@@ -0,0 +1,79 @@
+From 3f786481d49e25a089586df4656cab563c90ae41 Mon Sep 17 00:00:00 2001
+From: David <david@rowetel.com>
+Date: Thu, 25 Apr 2019 06:47:06 +0930
+Subject: [PATCH] removed unneeded dependancy on libspeex and libsamplerate,
+ these were just used for random misc programs
+
+---
+ CMakeLists.txt | 30 ------------------------------
+ unittest/CMakeLists.txt | 9 ---------
+ 2 files changed, 8 insertions(+), 48 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 669b8be1..6c8eae19 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -195,36 +195,6 @@ if(UNITTEST)
+ find_package(Threads REQUIRED)
+ message(STATUS "Threads library flags: ${CMAKE_THREAD_LIBS_INIT}")
+
+- #
+- # Find speex library
+- #
+- message(STATUS "Looking for Speex DSP library.")
+- find_path(SPEEXDSP_INCLUDE_DIR speex/speex_preprocess.h)
+- find_library(SPEEXDSP_LIBRARY speexdsp)
+- message(STATUS " Speex DSP headers: ${SPEEXDSP_INCLUDE_DIR}")
+- message(STATUS " Speex DSP library: ${SPEEXDSP_LIBRARY}")
+- if(NOT SPEEXDSP_INCLUDE_DIR AND NOT SPEEXDSP_LIBRARY)
+- message(FATAL_ERROR "Speex DSP library not found!")
+- endif()
+-
+- #
+- # Samplerate Library
+- #
+- message(STATUS "Looking for samplerate...")
+- find_library(LIBSAMPLERATE samplerate)
+- find_path(LIBSAMPLERATE_INCLUDE_DIR samplerate.h)
+- message(STATUS " samplerate headers: ${LIBSAMPLERATE_INCLUDE_DIR}")
+- message(STATUS " samplerate library: ${LIBSAMPLERATE}")
+- if(LIBSAMPLERATE AND LIBSAMPLERATE_INCLUDE_DIR)
+- list(APPEND FREEDV_LINK_LIBS ${CMAKE_REQUIRED_LIBRARIES})
+- include_directories(${LIBSAMPLERATE_INCLUDE_DIR})
+- else(LIBSTAMPLERATE AND LIBSAMPLERATE_INCLUDE_DIR)
+- message(FATAL_ERROR "samplerate library not found.
+-On Linux systems try installing:
+- samplerate-devel (RPM based systems)
+- libsamplerate-dev (DEB based systems)")
+- endif(LIBSAMPLERATE AND LIBSAMPLERATE_INCLUDE_DIR)
+-
+ add_subdirectory(unittest)
+ add_subdirectory(misc)
+ endif(UNITTEST)
+diff --git a/unittest/CMakeLists.txt b/unittest/CMakeLists.txt
+index 35a944fe..9b2e0e95 100644
+--- a/unittest/CMakeLists.txt
++++ b/unittest/CMakeLists.txt
+@@ -73,12 +73,6 @@
+ add_executable(tfifo tfifo.c ../src/fifo.c)
+ target_link_libraries(tfifo codec2 ${CMAKE_THREAD_LIBS_INIT})
+
+-add_executable(speexnoisesup speexnoisesup.c)
+-target_link_libraries(speexnoisesup ${SPEEXDSP_LIBRARY})
+-set_target_properties(speexnoisesup
+- PROPERTIES INCLUDE_DIRECTORIES ${SPEEXDSP_INCLUDE_DIR}
+-)
+-
+ add_executable(fdmdv_mem fdmdv_mem.c)
+
+ add_executable(raw2h raw2h.c)
+@@ -91,9 +85,6 @@
+ add_executable(tnewamp1 tnewamp1.c ../src/quantise.c ../src/newamp1.c ../src/mbest.c ../src/kiss_fft.c ../src/sine.c ../src/nlp.c ../src/dump.c ../src/octave.c ${CODEBOOKS})
+ target_link_libraries(tnewamp1 codec2)
+
+-add_executable(tsrc tsrc.c)
+-target_link_libraries(tsrc samplerate)
+-
+ add_executable(tlininterp tlininterp.c)
+ add_executable(tdec tdec.c)
+