summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-08-14 20:25:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-08-14 20:31:50 +0200
commit7e7d3d4e2cf3c69a1fb706900d4caf43a2b3fb66 (patch)
tree2d8dbfa2c36dfd8dc3014798e689bdfa53dbbbde /media-libs
parentnet-wireless/hackrf-tools: migrate to cmake.eclass (diff)
downloadgentoo-7e7d3d4e2cf3c69a1fb706900d4caf43a2b3fb66.tar.gz
gentoo-7e7d3d4e2cf3c69a1fb706900d4caf43a2b3fb66.tar.bz2
gentoo-7e7d3d4e2cf3c69a1fb706900d4caf43a2b3fb66.zip
media-libs/harfbuzz: Bump to version 2.7.1
switch from autotools to meson Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-2.7.1.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index d7d91446132c..354d2bf84938 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -2,3 +2,4 @@ DIST harfbuzz-2.6.5.tar.xz 8510596 BLAKE2B e495fbba7e0cb58918afeb6beb3ebcf936be8
DIST harfbuzz-2.6.7.tar.xz 9001936 BLAKE2B bd3a195506253a1446e877c35c067cc874826fc6fdae3bc3a9bfd2b7682ce12de7e6d7fd4ebe03b8178d8b678c06aa2d71715b27236347224a68e4d98a72039e SHA512 6fdd6e0952a73e1949349aa5416ef8fb3fc351b15c95be4fe1f341b111159fe58113b73a334db2697f4e3aaef5a761bd8f1d8964514406cad40f9862768d59de
DIST harfbuzz-2.6.8.tar.xz 8976516 BLAKE2B 46401ae06ec70172621d2aa354901f03173a273abdb0db909332946643e82b4286be690ac717a29304e9db121dd7f693b4ce19522de772f5d140986d6333e7ce SHA512 651b23d7d4fab6fef472ee57db39bbaebc31c2f40ea3a482c1499ad1a7b549b86a2bccbe9da191c8e9ecdf464191dd3c9a7485546b51695ad8ab3c0329732d9d
DIST harfbuzz-2.7.0.tar.gz 16278518 BLAKE2B 4d4bcbcd08c90cbdb34f8aca3571bcd836d578e7eab81187d7dba8a19ae586744b5f9ac83cfb6a50302648c502a87f4aa9dccdfbf39edc70d4318d831f4a55b0 SHA512 65d5b9bd3a53be659dd7d220da220f6873f7246c2ab11205132998e4ac4245fcf51b6968e705b81cc7652db5bbacc90c8db977cf1020edf7957a626a19e055c0
+DIST harfbuzz-2.7.1.tar.gz 16603949 BLAKE2B 4c1792dfb8f2c777efb2f01dfc7e4642bda507813d21db5beee467b1368e991db0f0c3f903662da0a267e7af9a6c30bb258fa057e42d3096f9f8d23ccf4bac9e SHA512 a04864e0f5e523e9d025f066e0850afdfdf53acc9881c0284034ab4384088b118551a899ae5e77bbd821c344b97fb5e0a3d4506bbb812eb0019080be7b3f75f1
diff --git a/media-libs/harfbuzz/harfbuzz-2.7.1.ebuild b/media-libs/harfbuzz/harfbuzz-2.7.1.ebuild
new file mode 100644
index 000000000000..774a139ec6a7
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-2.7.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit flag-o-matic libtool meson multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+
+IUSE="+cairo debug doc +glib +graphite icu +introspection static-libs test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ sed -i \
+ -e 's:tests/macos.tests::' \
+ test/shaping/data/in-house/Makefile.sources \
+ || die # bug 726120
+
+ if ! use doc ; then
+ # Taken from shipped autogen.sh script
+ echo "EXTRA_DIST = " > gtk-doc.make
+ fi
+
+ # bug 618772
+ append-cxxflags -std=c++14
+}
+
+meson_multilib_native_feature() {
+ if multilib_is_native_abi && use "$1" ; then
+ echo "enabled"
+ else
+ echo "disabled"
+ fi
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ local emesonargs=(
+ -Dcairo="$(meson_multilib_native_feature cairo)"
+ -Dcoretext="disabled"
+ -Ddocs="$(meson_multilib_native_feature doc)"
+ -Dfontconfig="disabled" #609300
+ #-Dgobject="$(meson_multilib_native_feature introspection)"
+ -Dintrospection="$(meson_multilib_native_feature introspection)"
+ -Dstatic="$(usex static-libs true false)"
+ $(meson_feature glib)
+ $(meson_feature graphite)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}