summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-20 18:50:54 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-20 18:50:54 +0100
commit91c02b6a97e4cc6ac17457640bb32c3d708093b3 (patch)
tree5fa9d8f3f093c25b3175611223f153904762952c /media-libs
parentdev-python/collectd-rabbitmq: depend on collectd with python enabled. (diff)
downloadgentoo-91c02b6a97e4cc6ac17457640bb32c3d708093b3.tar.gz
gentoo-91c02b6a97e4cc6ac17457640bb32c3d708093b3.tar.bz2
gentoo-91c02b6a97e4cc6ac17457640bb32c3d708093b3.zip
media-libs/adplug: Build live ebuild out of source
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/adplug/adplug-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-libs/adplug/adplug-9999.ebuild b/media-libs/adplug/adplug-9999.ebuild
index b44d43a3eae6..888886e9b783 100644
--- a/media-libs/adplug/adplug-9999.ebuild
+++ b/media-libs/adplug/adplug-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit out-of-source
+
DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
HOMEPAGE="http://adplug.sourceforge.net"
@@ -27,13 +29,13 @@ src_prepare() {
[[ ${PV} == *9999 ]] && eautoreconf
}
-src_configure() {
+my_src_configure() {
econf \
$(use_enable static-libs static) \
$(use_enable debug)
}
-src_install() {
- default
+my_src_install_all() {
+ einstalldocs
find "${D}" -name '*.la' -delete || die
}